0

I want to add this information to the question 'How to fix “The system is running in low-graphics mode” error?', but I'm newly registered and don't have the reputation to comment on that question.

Short recommendation: if you have both PAM errors and the low graphics problem, try to fix the PAM problems first.

My details: I had a working Ubuntu 32 bit 14.04 LTS system with an NVidia graphics card. I installed 64 bit 14.04 LTS on it, and then started installing additional packages and configurations as the 32 bit used to be configured, including NVidia drivers, Kerberos, LDAP and login time restrictions. After a reboot, I got the "low graphics" problem and could not log in at the console. Ssh password login for ordinary users failed. Fortunately, I had public key ssh root login working, so I could continue troubleshooting. I tried some fixes from the 'How to fix “The system is running in low-graphics mode” error?' question without success.

When making an ssh connection, auth.log recorded:

Mar 22 13:17:08 crookshanks sshd[1934]: PAM (sshd) illegal module type: login
Mar 22 13:17:08 crookshanks sshd[1934]: PAM pam_parse: expecting return value; [...account]
Mar 22 13:17:08 crookshanks sshd[1934]: PAM (other) illegal module type: login
Mar 22 13:17:08 crookshanks sshd[1934]: PAM pam_parse: expecting return value; [...account]
Mar 22 13:17:18 crookshanks sshd[1934]: pam_krb5(sshd:auth): user allan authenticated as allan@XXXXXXXXXX
Mar 22 13:17:18 crookshanks sshd[1934]: Failed password for allan from XXX.XXX.XXX.XXX port 60427 ssh2

Solution

I had this line in /etc/pam.d/common-account to enable time restrictions (it worked on the 32 bit installation):

login  account  required  pam_time.so

I commented that line out, rebooted, and the PAM problem disappeared, AND the 'low graphics' problem disappeared. I can't explain why the PAM error caused the low graphics error, but I hope this information helps someone else.

  • Please post your solution as an answer below. – Oli Apr 6 '16 at 14:47
0

Short recommendation: if you have both PAM errors and the low graphics problem, try to fix the PAM problems first.

I had this line in /etc/pam.d/common-account to enable time restrictions (it worked on the 32 bit installation):

login  account  required  pam_time.so

I commented that line out, rebooted, and the PAM problem disappeared, AND the 'low graphics' problem disappeared. Further testing showed that editing the line to:

account  required  pam_time.so

allowed the time restrictions to work without causing PAM errors or the low graphics error. I can't explain why the PAM error caused the low graphics error, but I hope this information helps someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.