3

,Simply put, I cannot get lm sensors to return my CPU temp. I am running Lubuntu 15.10 (up to date) with an AMD 8350 CPU on a Gigabyte GA-78LMT-USB3 motherboard. What I've done, and the output:

Installation:

sudo apt-get install lm-sensors
sudo sensors-detect

(see: output at bottom of post)

Added it87 and coretemp to /etc/modules (rebooted, to no avail)

Installed the following (sudo make, sudo make install...): https://github.com/groeck/it87

Any ideas?

Output from sensors (post config):

sensors
it8620-isa-0228
Adapter: ISA adapter
in0:          +0.90 V  (min =  +0.00 V, max =  +3.06 V)

in1:          +1.50 V  (min =  +0.00 V, max =  +3.06 V)

in2:          +2.04 V  (min =  +0.00 V, max =  +3.06 V)

in3:          +1.84 V  (min =  +0.00 V, max =  +3.06 V)

in4:          +2.03 V  (min =  +0.00 V, max =  +3.06 V)

in5:          +2.23 V  (min =  +0.00 V, max =  +3.06 V)

in6:          +2.23 V  (min =  +0.00 V, max =  +3.06 V)

3VSB:         +3.31 V  (min =  +0.00 V, max =  +6.12 V)

Vbat:         +2.76 V  

fan1:         986 RPM  (min =    0 RPM)

fan2:         721 RPM  (min =    0 RPM)

fan3:           0 RPM  (min =    0 RPM)

temp1:        +34.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermistor

temp2:        +27.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermal diode

temp3:        +27.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = Intel PECI

intrusion0:  ALARM

fam15h_power-pci-00c4

Adapter: PCI adapter

power1:       41.74 W  (crit = 125.19 W)


k10temp-pci-00c3

Adapter: PCI adapter

temp1:        +11.5°C  (high = +70.0°C)

(crit = +80.0°C, hyst = +77.0°C)

Output from "sensors-detect":


# sensors-detect revision 6284 (2015-05-31 14:00:33 +0200)
# System: Gigabyte Technology Co., Ltd. GA-78LMT-USB3 6.0
# Kernel: 4.2.0-34-generic x86_64
# Processor: AMD FX(tm)-8350 Eight-Core Processor (21/2/0)

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you're doing.

Some south bridges, CPUs or memory controllers contain embedded sensors.
Do you want to scan for them? This is totally safe. (YES/no): 
Module cpuid loaded successfully.
Silicon Integrated Systems SIS5595...                       No
VIA VT82C686 Integrated Sensors...                          No
VIA VT8231 Integrated Sensors...                            No
AMD K8 thermal sensors...                                   No
AMD Family 10h thermal sensors...                           No
AMD Family 11h thermal sensors...                           No
AMD Family 12h and 14h thermal sensors...                   No
AMD Family 15h thermal sensors...                           Success!
    (driver `k10temp')
AMD Family 16h thermal sensors...                           No
AMD Family 15h power sensors...                             Success!
    (driver `fam15h_power')
AMD Family 16h power sensors...                             No
Intel digital thermal sensor...                             No
Intel AMB FB-DIMM thermal sensor...                         No
Intel 5500/5520/X58 thermal sensor...                       No
VIA C7 thermal sensor...                                    No
VIA Nano thermal sensor...                                  No

Some Super I/O chips contain embedded sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no): 
Probing for Super-I/O at 0x2e/0x2f
Trying family `National Semiconductor/ITE'...               No
Trying family `SMSC'...                                     No
Trying family `VIA/Winbond/Nuvoton/Fintek'...               No
Trying family `ITE'...                                      Yes
Found `ITE IT8620E Super IO Sensors'                        Success!
    (address 0x228, driver `it87')
Probing for Super-I/O at 0x4e/0x4f
Trying family `National Semiconductor/ITE'...               No
Trying family `SMSC'...                                     No
Trying family `VIA/Winbond/Nuvoton/Fintek'...               No
Trying family `ITE'...                                      No

Some systems (mainly servers) implement IPMI, a set of common interfaces
through which system health data may be retrieved, amongst other things.
We first try to get the information from SMBIOS. If we don't find it
there, we have to read from arbitrary I/O ports to probe for such
interfaces. This is normally safe. Do you want to scan for IPMI
interfaces? (YES/no): 
Probing for `IPMI BMC KCS' at 0xca0...                      No
Probing for `IPMI BMC SMIC' at 0xca8...                     No

Some hardware monitoring chips are accessible through the ISA I/O ports.
We have to write to arbitrary I/O ports to probe them. This is usually
safe though. Yes, you do have ISA I/O ports even if you do not have any
ISA slots! Do you want to scan the ISA I/O ports? (yes/NO): 

Lastly, we can probe the I2C/SMBus adapters for connected hardware
monitoring devices. This is the most risky part, and while it works
reasonably well on most systems, it has been reported to cause trouble
on some systems.
Do you want to probe the I2C/SMBus adapters now? (YES/no): 
Using driver `i2c-piix4' for device 0000:00:14.0: ATI Technologies Inc SB600/SB700/SB800 SMBus

Next adapter: Radeon i2c bit bus 0x90 (i2c-0)
Do you want to scan it? (yes/NO/selectively): 

Next adapter: Radeon i2c bit bus 0x91 (i2c-1)
Do you want to scan it? (yes/NO/selectively): 

Next adapter: Radeon i2c bit bus 0x92 (i2c-2)
Do you want to scan it? (yes/NO/selectively): 

Next adapter: Radeon i2c bit bus 0x93 (i2c-3)
Do you want to scan it? (yes/NO/selectively): 

Next adapter: Radeon i2c bit bus 0x14 (i2c-4)
Do you want to scan it? (yes/NO/selectively): 


Now follows a summary of the probes I have just done.
Just press ENTER to continue: 

Driver `k10temp' (autoloaded):
  * Chip `AMD Family 15h thermal sensors' (confidence: 9)

Driver `fam15h_power' (autoloaded):
  * Chip `AMD Family 15h power sensors' (confidence: 9)

Driver `it87':
  * ISA bus, address 0x228
    Chip `ITE IT8620E Super IO Sensors' (confidence: 9)

To load everything that is needed, add this to /etc/modules:
#----cut here----
# Chip drivers
it87
#----cut here----
If you have some drivers built into your kernel, the list above will
contain too many modules. Skip the appropriate ones!

Do you want to add these lines automatically to /etc/modules? (yes/NO)

Unloading cpuid... OK
3

So you have run sudo sensors-detect accepted its defaults and allowed it to add it87 and coretemp to /etc/modules yet you don't see the outputs from the it87 chip.

If you run lsmod from a terminal you will find coretemp but it87 is not there.

The answer is to edit /etc/default/grub. You need to append acpi_enforce_resources=lax at the end of the line GRUB_CMDLINE_LINUX. Here is a screenshot of mine with the relevant line highlighted.

screenshot of my etc/default/grub

Then sudo update-grub followed by a reboot.

The it87 sensor outputs will now appear. You will then need to create or find a configuration file for your motherboard and insert it in /etc/sensors.d.

If done properly this will give meaningful names to all the temperatures, voltages and fan speeds detected, discard outputs from any sensors not connected to anything, set reasonable limits and calculate the values of voltages sensed using voltage divider resistors. Here is a screenshot of my it87 outputs using xsensors.

Screenshot of it87 output from my PC using xsensors

  • Hi Steve, thanks for the information! Firstly, when I run lsmod - it87 does in fact appear, but coretemp does not. I've done everything else, but I'm not sure how to make or find a config file. Any hints? – Matt Apr 25 '16 at 16:04
  • Try googling the name of your motherboard followed by lm-sensors configuration. Its easy to write your own instructions here. wiki.archlinux.org/index.php/lm_sensors. The key is to make sure the values returned by sensors match the values returned by your BIOS. If you run into trouble ask a new question stating the make and number of your motherboard, and showing the output from sensors. A photo of the values from the BIOS would also be useful. – Steve Roome Apr 25 '16 at 18:20
0

temp3 is your CPU temperature. Intel PECI is the bridge between temperature sensors and the OS.

Source: http://www.intel.com/content/www/us/en/embedded/testing-and-validation/cpu-monitoring-dts-peci-paper.html

  • Many thanks for the edit (above) and the answer. I'm curious, however, why I don't see core temperatures similar to what others get with the sensor command? – Matt Mar 21 '16 at 17:25
  • Do you have a custom-built computer? It's possible manufacturers set names for the sensors. – TheWanderer Mar 21 '16 at 17:32
  • I built it myself, yes - it's part of a cluster I've made for parallel computing. CPU will be under heavy load, so I'm very worried about watching the temperature. – Matt Mar 21 '16 at 17:34
  • Well, that one should be the sensor. – TheWanderer Mar 21 '16 at 17:34
  • Of note: BIOS shows 36C resting, and the PECI consistently shows 27C... Are you sure the temp3 channel is the CPU, or could temp1 be it? – Matt Mar 21 '16 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.