6

As the title say my laptop battery is not detected in maverick. I'm using ubuntu since ever and I've never come across this problem. I have a msi ms-171f vr705 series and everything is working fine except for the battery.

cat: /proc/acpi/battery/BAT1/info: No such device
1
4

Usually the Laptop battery is labelled BAT0. Have you tried running:

cat /proc/acpi/battery/BAT0/info

Also have you tried adding acpi=force onto your GRUB command line?

Open a terminal and run the following commands:

  1. sudo gedit /etc/default/grub
  2. Go to the line GRUB_CMDLINE_LINUX_DEFAULT=""
  3. Replace it with GRUB_CMDLINE_LINUX_DEFAULT="acpi=force"
  4. Save your changes.
  5. Run sudo update-grub and reboot.

(If there is something already within the "" at Step 2 just add a space after it and add acpi=force)

3
  • thank you no there is no BAT0 i've always had BAT1 i think the laptop is able to include two batteries via usb or i don't know anyway i'll try to add acpi=force to grub and see how it goes..
    – Px Mohamed
    Oct 15 '10 at 12:53
  • OK I forgot to add after you make the update run sudo update-grub afterwards Oct 15 '10 at 13:01
  • 1
    i tried acpi=force and it didn't fix the problem..i'll apply all the updates and see what happens any suggestions are welcome
    – Px Mohamed
    Oct 15 '10 at 13:20
3

I know this question is a bit old, but someone may benefit from my reply. The problem is caused by an upstream kernel bug. You can view the bug report here: https://bugzilla.kernel.org/show_bug.cgi?id=24002. The last version of Ubuntu with a kernel that showed battery information from a MS-171F laptop motherboard was 9.10 (Karmic). Unfortunately, Karmic reached its end of life date in April. Hopefully they will have the problem resolved soon and it will filter down to us in an update.

1
  • 2
    actually i didn't have the problem until maverick (it was detected in lucid) anyway i'm still waiting for a fix ....
    – Px Mohamed
    Jul 3 '11 at 18:15
0

Open a terminal and run the following commands:

sudo gedit /etc/default/grub Find the line GRUB_CMDLINE_LINUX_DEFAULT="" Replace it with GRUB_CMDLINE_LINUX_DEFAULT="acpi=noacpi" Save your changes. Run sudo update-grub and reboot.

If it doesn't work and you have external graphics like nvdia, then update and make latest version of the driver as default and then check. I have a MSI GF-63 and it worked.

1
  • are you sure disabling ACPI is a good idea? After all, the battery shows up under /proc/acpi ?!?
    – Mathieu J.
    Mar 18 at 0:04
0

in my case, this happen often after I upgrade kernel and I don't reboot as often as suggested.

after I rebooted, it worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.