0

I have installed Ubuntu on a new HP Windows 10 laptop, but the wifi is not working. Nothing happens when I click Enable Wifi and Wifi Networks is greyed out. Wifi works ok in Windows.

Wireless info is below.

I note that rfkill shows a soft block,

2: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

But sudo rfkill unblock wifi doesn't change anything.

Any suggestions on how to resolve?

#### wireless info START

Report from: 21 Mar 2016 10:12 GMT +0000

Booted last: 21 Mar 2016 09:40 GMT +0000

Script from: 27 Sep 2015 00:34 UTC +0000

release

Distributor ID: Ubuntu Description: Ubuntu 14.04.4 LTS Release: 14.04 Codename: trusty

kernel

Linux 4.2.0-27-generic #32~14.04.1-Ubuntu SMP Fri Jan 22 15:32:26 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

desktop

Ubuntu

lspci

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 07) Subsystem: Hewlett-Packard Company Device [103c:8074] Kernel driver in use: r8169

03:00.0 Network controller [0280]: Intel Corporation Wireless 3165 [8086:3165] (rev 81) Subsystem: Intel Corporation Dual Band Wireless AC 3165 [8086:4010] Kernel driver in use: iwlwifi

lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 006: ID 0bda:57c4 Realtek Semiconductor Corp. Bus 001 Device 005: ID 8087:0a2a Intel Corp. Bus 001 Device 004: ID 05e3:0610 Genesys Logic, Inc. 4-port hub Bus 001 Device 002: ID 0483:91d1 STMicroelectronics Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

PCMCIA card info rfkill

0: hci0: Bluetooth Soft blocked: no Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: no 2: acer-wireless: Wireless LAN Soft blocked: yes Hard blocked: no

lsmod

acer_wmi 20480 0 hp_wmi 16384 0 sparse_keymap 16384 2 acer_wmi,hp_wmi iwlmvm 290816 0 mac80211 729088 1 iwlmvm iwlwifi 204800 1 iwlmvm cfg80211 540672 3 iwlwifi,mac80211,iwlmvm wmi 20480 2 acer_wmi,hp_wmi video 36864 2 i915,acer_wmi

interfaces

auto lo iface lo inet loopback

ifconfig

eth0 Link encap:Ethernet HWaddr
inet addr:192.168.1.18 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:8911 errors:0 dropped:0 overruns:0 frame:0 TX packets:4545 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:7349744 (7.3 MB) TX bytes:455446 (455.4 KB)

wlan0 Link encap:Ethernet HWaddr
BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

iwconfig

eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry short limit:7 RTS thr:off Fragment thr:off Power Management:on

route

Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0 192.168.1.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0

resolv.conf

nameserver 127.0.1.1 search Home

network managers

Installed:

NetworkManager

Running:

root 3502 1 0 10:06 ? 00:00:00 NetworkManager

NetworkManager info

NetworkManager Tool

State: connected (global)

  • Device: wlan0 ---------------------------------------------------------------- Type: 802.11 WiFi Driver: iwlwifi State: unavailable Default: no HW Address:

    Capabilities:

    Wireless Properties WEP Encryption: yes WPA Encryption: yes WPA2 Encryption: yes

    Wireless Access Points

  • Device: eth0 [Wired connection 1] ------------------------------------------- Type: Wired Driver: r8169 State: connected Default: yes HW Address:

    Capabilities: Carrier Detect: yes Speed: 100 Mb/s

    Wired Properties Carrier: on

    IPv4 Settings: Address: 192.168.1.18 Prefix: 24 (255.255.255.0) Gateway: 192.168.1.1

    DNS: 192.168.1.1

NetworkManager.state

[main] NetworkingEnabled=true WirelessEnabled=true WWANEnabled=true WimaxEnabled=true

NetworkManager.conf

[main] plugins=ifupdown,keyfile,ofono dns=dnsmasq

[ifupdown] managed=false

NetworkManager profiles iw reg get

Region: Europe/London (based on set time zone)

country 00: (2402 - 2472 @ 40), (3, 20) (2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS (2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS (5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS (5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS

iwlist channels

eth0 no frequency information.

lo no frequency information.

wlan0 32 channels in total; available frequencies : Channel 01 : 2.412 GHz Channel 02 : 2.417 GHz Channel 03 : 2.422 GHz Channel 04 : 2.427 GHz Channel 05 : 2.432 GHz Channel 06 : 2.437 GHz Channel 07 : 2.442 GHz Channel 08 : 2.447 GHz Channel 09 : 2.452 GHz Channel 10 : 2.457 GHz Channel 11 : 2.462 GHz Channel 12 : 2.467 GHz Channel 13 : 2.472 GHz Channel 36 : 5.18 GHz Channel 40 : 5.2 GHz Channel 44 : 5.22 GHz Channel 48 : 5.24 GHz Channel 52 : 5.26 GHz Channel 56 : 5.28 GHz Channel 60 : 5.3 GHz Channel 64 : 5.32 GHz Channel 100 : 5.5 GHz Channel 104 : 5.52 GHz Channel 108 : 5.54 GHz Channel 112 : 5.56 GHz Channel 116 : 5.58 GHz Channel 120 : 5.6 GHz Channel 124 : 5.62 GHz Channel 128 : 5.64 GHz Channel 132 : 5.66 GHz Channel 136 : 5.68 GHz Channel 140 : 5.7 GHz

iwlist scan

eth0 Interface doesn't support scanning.

wlan0 Interface doesn't support scanning : Network is down

lo Interface doesn't support scanning.

module infos

[iwlmvm] filename: /lib/modules/4.2.0-27-generic/kernel/drivers/net/wireless/iwlwifi/mvm/iwlmvm.ko license: GPL author: Copyright(c) 2003- 2015 Intel Corporation description: The new Intel(R) wireless AGN driver for Linux srcversion: 3BBD88D7E8252B90136F463 depends: iwlwifi,mac80211,cfg80211 intree: Y vermagic: 4.2.0-27-generic SMP mod_unload modversions signer: Build time autogenerated kernel key sig_key: 73:6E:2F:9E:A1:B4:72:8A:15:AC:16:9B:18:69:26:7E:11:28:D6:E8 sig_hashalgo: sha512 parm: init_dbg:set to true to debug an ASSERT in INIT fw (default: false (bool) parm: power_scheme:power management scheme: 1-active, 2-balanced, 3-low power, default: 2 (int) parm: tfd_q_hang_detect:TFD queues hang detection (default: true (bool)

[mac80211] filename: /lib/modules/4.2.0-27-generic/kernel/net/mac80211/mac80211.ko license: GPL description: IEEE 802.11 subsystem srcversion: FBF6EA073A00B4F3836226E depends: cfg80211 intree: Y vermagic: 4.2.0-27-generic SMP mod_unload modversions signer: Build time autogenerated kernel key sig_key: 73:6E:2F:9E:A1:B4:72:8A:15:AC:16:9B:18:69:26:7E:11:28:D6:E8 sig_hashalgo: sha512 parm: minstrel_vht_only:Use only VHT rates when VHT is supported by sta. (bool) parm: max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int) parm: max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int) parm: beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int) parm: probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int) parm: ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[iwlwifi] filename: /lib/modules/4.2.0-27-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko license: GPL author: Copyright(c) 2003- 2015 Intel Corporation description: Intel(R) Wireless WiFi driver for Linux firmware: iwlwifi-100-5.ucode firmware: iwlwifi-1000-5.ucode firmware: iwlwifi-135-6.ucode firmware: iwlwifi-105-6.ucode firmware: iwlwifi-2030-6.ucode firmware: iwlwifi-2000-6.ucode firmware: iwlwifi-5150-2.ucode firmware: iwlwifi-5000-5.ucode firmware: iwlwifi-6000g2b-6.ucode firmware: iwlwifi-6000g2a-5.ucode firmware: iwlwifi-6050-5.ucode firmware: iwlwifi-6000-4.ucode firmware: iwlwifi-7265D-12.ucode firmware: iwlwifi-7265-12.ucode firmware: iwlwifi-3160-12.ucode firmware: iwlwifi-7260-12.ucode firmware: iwlwifi-8000-12.ucode srcversion: 75997E53B9CC3BD2CA79F3B depends: cfg80211 intree: Y vermagic: 4.2.0-27-generic SMP mod_unload modversions signer: Build time autogenerated kernel key sig_key: 73:6E:2F:9E:A1:B4:72:8A:15:AC:16:9B:18:69:26:7E:11:28:D6:E8 sig_hashalgo: sha512 parm: swcrypto:using crypto in software (default 0 [hardware]) (int) parm: 11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint) parm: amsdu_size_8K:enable 8K amsdu size (default 0) (int) parm: fw_restart:restart firmware in case of error (default true) (bool) parm: antenna_coupling:specify antenna coupling in dB (default: 0 dB) (int) parm: nvm_file:NVM file name (charp) parm: d0i3_disable:disable d0i3 functionality (default: Y) (bool) parm: lar_disable:disable LAR functionality (default: N) (bool) parm: uapsd_disable:disable U-APSD functionality (default: Y) (bool) parm: bt_coex_active:enable wifi/bt co-exist (default: enable) (bool) parm: led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int) parm: power_save:enable WiFi power management (default: disable) (bool) parm: power_level:default power save level (range from 1 - 5, default: 1) (int) parm: fw_monitor:firmware monitor - to debug FW (default: false - needs lots of memory) (bool)

[cfg80211] filename: /lib/modules/4.2.0-27-generic/kernel/net/wireless/cfg80211.ko description: wireless configuration support license: GPL author: Johannes Berg srcversion: 7982686FBE8064A87E02753 depends:
intree: Y vermagic: 4.2.0-27-generic SMP mod_unload modversions signer: Build time autogenerated kernel key sig_key: 73:6E:2F:9E:A1:B4:72:8A:15:AC:16:9B:18:69:26:7E:11:28:D6:E8 sig_hashalgo: sha512 parm: ieee80211_regdom:IEEE 802.11 regulatory domain code (charp) parm: cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

module parameters

[iwlmvm] init_dbg: N power_scheme: 2 tfd_q_hang_detect: Y

[mac80211] beacon_loss_count: 7 ieee80211_default_rc_algo: minstrel_ht max_nullfunc_tries: 2 max_probe_tries: 5 minstrel_vht_only: Y probe_wait_ms: 500

[iwlwifi] 11n_disable: 0 amsdu_size_8K: 0 antenna_coupling: 0 bt_coex_active: Y d0i3_disable: Y fw_monitor: N fw_restart: Y lar_disable: N led_mode: 0 nvm_file: (null) power_level: 0 power_save: N swcrypto: 0 uapsd_disable: Y

[cfg80211] cfg80211_disable_40mhz_24ghz: N ieee80211_regdom: 00

/etc/modules

lp rtc

modprobe options

[/etc/modprobe.d/blacklist-ath_pci.conf] blacklist ath_pci

[/etc/modprobe.d/blacklist.conf] blacklist evbug blacklist usbmouse blacklist usbkbd blacklist eepro100 blacklist de4x5 blacklist eth1394 blacklist snd_intel8x0m blacklist snd_aw2 blacklist i2c_i801 blacklist prism54 blacklist bcm43xx blacklist garmin_gps blacklist asus_acpi blacklist snd_pcsp blacklist pcspkr blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf] alias net-pf-3 off alias net-pf-6 off alias net-pf-9 off alias net-pf-11 off alias net-pf-12 off alias net-pf-19 off alias net-pf-21 off alias net-pf-36 off

[/etc/modprobe.d/iwlwifi.conf] remove iwlwifi \ (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \ && /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf] softdep mlx4_core post: mlx4_en

rc.local

exit 0

pm-utils udev rules

[/etc/udev/rules.d/70-persistent-net.rules] PCI device 0x10ec:0x8136 (r8169) SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?", ATTR{address}=="", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth", NAME="eth0" PCI device 0x8086:0x3165 (iwlwifi) SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?", ATTR{address}=="", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan", NAME="wlan0"

dmesg

[ 26.999775] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled (repeated 4 times) [ 27.075037] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 28.028036] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled (repeated 4 times) [ 28.104823] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 331.502398] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled (repeated 4 times) [ 331.581113] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 341.650821] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled (repeated 4 times) [ 341.728842] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 356.965279] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled (repeated 4 times) [ 357.043941] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 1086.794294] r8169 0000:02:00.0 eth0: link up [ 1086.794344] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready [ 1212.082820] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled (repeated 4 times) [ 1212.160425] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 1538.489354] r8169 0000:02:00.0 eth0: link down (repeated 2 times) [ 1538.489481] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 1540.096595] r8169 0000:02:00.0 eth0: link up [ 1540.096620] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready [ 1548.968005] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled (repeated 4 times) [ 1549.048818] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 1555.640263] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled (repeated 4 times) [ 1555.726240] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 1676.304184] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled (repeated 4 times) [ 1676.383070] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

#### wireless info END ############
2

This can be temporarily fixed by

sudo modprobe -r acer_wmi

To fix it permanently you need to blacklist this module.

But a better solution is to report this issue to Launchpad to get it fixed upstream.

  • Thanks that seems to have resolved it, and adding "blacklist acer_wmi" to /etc/modprobe.d/blacklist.conf. I don't know what Launchpad is. – PerceptualRobotics Mar 21 '16 at 13:12
  • Launchpad is where you report Ubuntu bugs. Run ubuntu-bug linux with not blacklisted module and create a bur report. This way it can be fixed for your laptop model without blacklisting. – Pilot6 Mar 21 '16 at 13:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.