1

After installing Ubuntu 14.04.3 on a HP Pavilion G6 that had windows 8.1 pre-installed, I am unable to see the grub menu. I can see two entries of Ubuntu if I hit the Esc key while booting and press F9 to go into boot menu. Ubuntu boots fine if either entry is selected. (note:Secure boot is disabled in BIOS. Legacy is also turned off.)

First I tried boot-repair (default) which announced that it has successfully repaired the boot, but the situation did not change.

Then I tried the 'bcdedit' method shown here: Grub not showing on startup for Windows 8.1 Ubuntu 13.10 Dual boot I now find 4 Ubuntu entries in the boot-menu, but still grub does not show up automatically.

Is there anything else I could try? Thanks in advance for any suggestions.

  • This might help askubuntu.com/questions/371559/… – Err0rr Mar 21 '16 at 8:25
  • Edit: I find that every time windows shuts down, it adds two more Ubuntu entries in the boot menu (i.e., using F9)! Can anyone tell me how to undo the effect of the bcdedit command? – blackpearl Mar 22 '16 at 4:48
1

I finally solved the problem by running boot-repair once again in advanced mode with 'Backup and Rename EFI Files' ticked.

0

There are 3 things you have to do :

  1. Disable Windows fast startup.

Open Windows Control Panel - Power Settings - uncheck Fast startup.

  1. Disable Windows hibernation.

Open command prompt as administrator and execute this command :

powercfg /h off  
  1. Set Ubuntu to be the default booting operating system in BIOS.
-1

This is not a big issue.

Launch Terminal (CTRL + ALT + T) and run:

sudo update-grub

That should fix the issue.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.