I'm not sure where to start with this one. (Warning, this could be a virtualbox question and not an Ubuntu question)

I have ubuntu 14.04.02_64 running in virtual box 5.0.16r on a windows 10 machine.

This was a clean install from a week ago. My first step was to install the AMP in LAMP using the instructions at https://www.howtoforge.com/ubuntu-lamp-server-with-apache2-php5-mysql-on-14.04-lts

for the last week, I've been using this VM and successfully connecting to the internet through the NAT network connection. No problems.

This evening I messed with the apache2 settings, using the instructions at https://www.howtoforge.com/ubuntu-lamp-server-with-apache2-php5-mysql-on-14.04-lts (during which time I pointed my local host to /home/server/public_html [yes, the machine's name is "server" and no, it's not a server version of ubuntu])

here's where it gets weird.

I had noticed yesterday that my clipboard was not being shared from the host (win10) into the ubuntu box, and decided to restart the VM.

Before I restarted I had internet connectivity in the VM.

After the restart the VM came up and informed me that I didn't have a network connection.

I went out to Virtual box and sure enough, my network settings showed "attached to" set to blank, so I set it back to NAT and restarted. - No joy

I did a search for "ubuntu disconnected you are now offline" (the text of the message) and find a lot of people not being connected in the first place.

For what I'm doing I don't have to have internet connectivity, I'm just working in localhost (learning php and mysql), but this seemed like the perfect opportunity to learn through doing, so here we are.

Is it weird that I lost connection after playing with the apache2 settings. Is the lack of clipboard sharing a symptom or just a red-herring?

How do I trouble shoot this, I've never been a network person so I'm not sure what basic data I should be putting in this question.


There are 2 Issues you have reported from what I could understand and this is NOT related to Apache settings.

  1. Network Connectivity
  2. Clipboard Sharing

The clipboard sharing can be enabled/disabled in the Vbox after starting it. By > devices->Shared clipboard ->bidirectional or one way if you prefer.

The network connectivity can be enabled by two ways, if you select NAT, be sure to configure it using the networking applet in the right conner.

The alternative is to use the networking settings in Vbox to "Bridged Mode". And after starting the instance, go to the network settings and use DHCP if your router/switch can assign additional IPs or else you can try assigning them yourselves.

Let me know, if this solved your issue.

  • This is helpful. I started by troubleshooting the clipboard sharing. -first, the settings were correctly set, just not functional. Turns out that the guest additions had failed. reinstalling the guest additions has fixed the clipboard sharing. Now to troubleshoot the network connectivity. Mar 21 '16 at 17:32
  • looks like making changes to my apache2 settings altered my /etc/network/interfaces settings, changing them from eth0 to lo. Found that suggestion here - askubuntu.com/questions/491729/… Mar 21 '16 at 17:49
  • discovered that my /etc/resolv.conf file is empty. Tried fixing it using solution found at askubuntu.com/questions/137037/… (sudo dpkg-reconfigure resolvconf) didn't help, but seems to be confirming that apache2 changed something (to be exact, it seems to confirm that I changed something when I was configuring apache2 to change the directory it was serving content from) Mar 21 '16 at 18:24
  • the nat settings seem to be correct, but I'd be happy to try out "bridge mode" - the problem that I'm having is that I'm not sure how to baby step through the problem, and since I don't have connectivity, apt-install <anything> isn't going to help. question do you know of a good networking troubleshooting guide for the non-networking person? I don't know from DHCP to DNS or how the resolv.conf is being loaded from. Mar 21 '16 at 21:00
  • A good start would be help.ubuntu.com/lts/serverguide/network-configuration.html and help.ubuntu.com/community/NetworkConfigurationCommandLine/… . But in the scenario you have described, I can suggest adding the interface manually. for info on how to do it, please refer this cyberciti.biz/faq/setting-up-an-network-interfaces-file . Should you require further assistance, please do revert. Mar 23 '16 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.