2

I'm not very experienced with Ubuntu and using code commands in terminal, so I feel like there is an answer out there on the other posts but it's too confusing for me to understand.

Using Virtual Box 5.0.16 Host OS is Mac OS 10.9.5 Guest OS (I gather this means the OS on the virtual machine I am running in Virtual Box) is Ubuntu 14.04 LTS

I've got my shared folder in Mac OS host set up with full sharing & permissions to users in the info box (i.e. Gramdalf (me), staff, everyone all as Read & Write).

I've got it set up in Virtual box for the guest ubuntu virtual machine in shared folders as auto-mounted and full access. The folder name is sharethisfolder.

Running guest ubuntu when I pull up file menu, on left under Devices it shows up as sf_sharethisfolder. It has an eject icon like other drives. But I click on it and get: 'This location could not be displayed. You do not have the permissions necessary to view the contents of "sf_sharethisfolder"'

I googled. I got suggestion to install guest additions. In virtualbox it looked like I did not need to download this as I had the option already to mount it in ubuntu and run installer. I did that. Still same error, so to be sure I downloaded vboxguestadditions_5.0.16, mounted out of my downloads folder, and tried to run the installer again. It ran but seemed to tell me it was already installed although a bunch of scripts ran and I don't know what it was all about, whether reinstalling... uninstalling, I have no idea what it did. I assumed it did not undo progress.

I then read in an answer on a seemingly related post, I think How to access a shared folder in VirtualBox? and run this: VBoxManage sharedfolder add "VM name" --name "sharename" --hostpath "C:\test"

I tried in ubuntu terminal and it gave me: The program 'VBoxManage' is currently not installed. You can install it by typing: sudo apt-get install virtualbox

So I did. It seemed to install it.

Now it appears I am ready to try again but... I can't follow what parts of that command I am supposed to sub with the actual names of my folders for my situation.

Did I screw anything up/am I at all on the right track? Can someone please explain to me in simpler terms exactly what I have to do now to not get that error and start sharing some folders? Would really appreciate some guidance.

  • Sorry for the confusion in the post you linked to. The VBoxManage commad needs to be run from the host, not the guest. You should remove virtualbox from the guest, as nested VMs are not possible. – Takkat Mar 21 '16 at 9:29
  • 1
    So I figured out the command line you were suggesting for terminal on my mac os, and it seems to just be the same thing as adding the folder through virtual box. Was it supposed to produce a different result by adding the folder to shared folders using terminal rather than in virtualbox? I noticed actually it didn't auto-mount in the guest, so I went into settings and checked off auto-mount, so now it shows up in ubuntu guest. But still same error: This location could not be displayed. You do not have the permissions necessary to view the contents of "sf_sharethisfolder" – gramdalf Mar 24 '16 at 1:56
  • Do you have a solution yet? I have the same problem – Richard Apr 20 '16 at 7:07
0

I was also seeing this problem running Ubuntu in VirtualBox on OS X.

The solution I found was to add my user name to the vboxsf group in /etc/group. Then log out and log in again. Then everything worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.