I was recently doing some tinkering to try to get my Thinkpad w550s working properly with an ultra dock and multiple displays - in doing this it appears as though I have removed some packages necessary for X and Unity to operate properly. When I boot into Ubuntu I'm thrown into a black screen. I can jump into a terminal so I am able to tinker around a bit.

I'm fairly certain this is where I broke it: https://ptpb.pw/SW9r/sh#L-9

Since realizing things no longer worked I have tried to install the ubuntu-desktop package but it seems apt is unhappy.

When I try to install ubuntu-desktop I get this:

Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed

I'm happy to provide any additional information that can help identify the actual problem as I am clearly speculating as to the actual problem.

EDIT: This problem was caused by packages for 15.10 being installed on this machine. Uncertain how I did this, but upon removing them and reinstalling the 14.04 packages all was well.


Try these websites...you might find your answer there:

  • Thanks - I tried the suggestions there and dumped the output of each on a pastebin: ptpb.pw/aQus The problem is not resolved after following the most upvoted answers on the articles provided. The output for apt-get install ubuntu-desktop is the same as in my original question. – Joe Pettit Mar 21 '16 at 4:29
  • Did you try installing ubuntu-desktop after doing the above? – x__x Mar 21 '16 at 4:32
  • Yes I did, the output is the same. Just edited my comment to reflect that. – Joe Pettit Mar 21 '16 at 4:32
  • I looked at the edit. It uninstalled a lot of important X packages. Frankly, I do not know the solution, but if I were you, I would reinstall Ubuntu - it takes less time than fixing stuff which may break in the future. Best of luck. – x__x Mar 21 '16 at 4:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.