I have a new Asus X540S and the mic is not working.

It's enable in sound/input, is not mute. I try this:

Internal microphone not working

  • have you solved your problem? – user47206 Apr 14 '17 at 21:23

In terminal:

sudo apt-get install alsa-tools-gui

Then: Show unconnected pins, override pin 0x12 to internal mic. Install boot override.

It worked in Ubuntu 14.04

  • why exactly 0x12? – user47206 Apr 14 '17 at 9:46
  • this worked. It only needs (after the setting) to ensure that the mic level is high enough in sound settings (pavucontrol, etc) – user47206 Apr 14 '17 at 10:18
  • unix.stackexchange.com/q/358741/32012 – user47206 Apr 14 '17 at 10:24

Edit this configuration file:

sudo nano /etc/modprobe.d/alsa-base.conf

And add this line:

options snd-hda-intel index=0 model=laptop-dmic
  • Do I need to restart anything after? – TrySpace Feb 8 '18 at 8:11
  • Didn't help, is the index supposed to be the soundcard #? – TrySpace Feb 22 '18 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.