I bought a new laptop ASUS-X556UF and installed Ubuntu 14.04 in it. Now I was trying to install Nvidia drivers according to the tutorial.

At this point I noticed the problem with my system. When I switched to command line mode ( Ctrl+Alt+F1) there was continuous error display on my console. So I accessed my syslog to verify it. The same error was flushing my /var/log/syslog file. Below is the error I got:

Mar 20 05:27:41 Asus-X556UF kernel: [  615.993338] pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00000001/00002000
Mar 20 05:27:41 Asus-X556UF kernel: [  615.993342] pcieport 0000:00:1c.5:    [ 0] Receiver Error         (First)
Mar 20 05:27:41 Asus-X556UF kernel: [  615.993351] pcieport 0000:00:1c.5: AER: Multiple Corrected error received: id=00e5
Mar 20 05:27:41 Asus-X556UF kernel: [  615.993700] pcieport 0000:00:1c.5: can't find device of ID00e5
Mar 20 05:27:41 Asus-X556UF kernel: [  615.993723] pcieport 0000:00:1c.5: AER: Multiple Corrected error received: id=00e5
Mar 20 05:27:41 Asus-X556UF kernel: [  615.994075] pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
Mar 20 05:27:41 Asus-X556UF kernel: [  615.994078] pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00000001/00002000
Mar 20 05:27:41 Asus-X556UF kernel: [  615.994080] pcieport 0000:00:1c.5:    [ 0] Receiver Error        
Mar 20 05:27:41 Asus-X556UF kernel: [  615.994090] pcieport 0000:00:1c.5: AER: Corrected error received: id=00e5
Mar 20 05:27:41 Asus-X556UF kernel: [  615.994439] pcieport 0000:00:1c.5: can't find device of ID00e5
Mar 20 05:27:41 Asus-X556UF kernel: [  615.994464] pcieport 0000:00:1c.5: AER: Multiple Corrected error received: id=00e5
Mar 20 05:27:41 Asus-X556UF kernel: [  615.994816] pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
Mar 20 05:27:41 Asus-X556UF kernel: [  615.994818] pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00000001/00002000
Mar 20 05:27:41 Asus-X556UF kernel: [  615.994820] pcieport 0000:00:1c.5:    [ 0] Receiver Error         (First)
Mar 20 05:27:41 Asus-X556UF kernel: [  615.994829] pcieport 0000:00:1c.5: AER: Corrected error received: id=00e5
Mar 20 05:27:41 Asus-X556UF kernel: [  615.994837] pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)

So I tried to search with what device my PCI bus 'ic' was connected and thus I ran below command:

$ lspci -v -s 1c.0 | grep Bus:
    Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
$ lspci -s 1:0
01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 930M]

It was connected to my graphics card. I don't know what causing this problem. Is it because of driver or something else.

I also tried to install the proprietary driver in Ubuntu through additional drivers tab. But what I got is the black screen at login screen.

Please let me know what causing the error and also help to install nVidia driver and use it.

Thanks

  • If you're on Ubuntu, you don't need to do any of that complicated setup. Just open the Additional Drivers app and select a proprietary video driver. – TheWanderer Mar 20 '16 at 12:54
  • I did this ....and selected the proprietary driver 352 but when i rebooted my system after that..i got black screen – Nitesh Bhutani Mar 20 '16 at 15:07
  • See if any of this helps askubuntu.com/questions/162075/… – TheWanderer Mar 20 '16 at 15:08
  • Nope tried this ...black screen only comes when i install proprietary nvidia driver through additional driver app. – Nitesh Bhutani Mar 20 '16 at 15:10
  • You may want to try installing Ubuntu 15.10 instead. The 930M is a pretty new card. – TheWanderer Mar 20 '16 at 15:11

I had exactly the same problem on Asus R556U. The problem was solved by booting with pci=nomsi (found the solution on this page)

In order to boot with pci=nomsi:

sudo cp /etc/default/grub /etc/default/grub.bak
sudo -H gedit /etc/default/grub

once the file is opened in gedit replace

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

with

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"

Save and close gedit window. Update grub and restart your system:

sudo update-grub
sudo reboot

I am on Ubuntu 16.04. Asus x455lf i3-4005u

I've got the same card, after days of fighting to install its binary drivers, I've found out that the drivers on the Ubuntu's repos were old for my card.

I've added ppa:graphics-drivers and installed nvidia-367 (367-44 for the record).

Now It works nice without any noticeable issues. Only minor corruption of unity panel after lock/switching account that I can sole with pressing meta key.

kernel:4.4.0-38-generic Un-modified /etc/default/grub

protected by Community Oct 5 '16 at 1:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.