I wanted to change permissions on my external drives that are automounted however I have tried by sudo nautilus and then going to gui and permissions and changing it however it does not let me.

I ran the ls -l and get

drwx------ 1 xbmc xbmc

the gui shows below.

owner xbmc
folder access create and delete files
file access ---

Group xbmc
folder access none
file access ---

folder access none
file access ---

how can I change it so that everyone has permission to access the drive and ALL folders/files inside of it. I am trying to get plexmedia server running and I cant see my drives via the webpage manage to add it to my source to be able to stream my content.

I want to change the "others" access so that I can access all my drives on the /media path to get read and write for all my folders from anywhere.

you can see my drives that are mounted here (external drives are #18,19,20) http://paste2.org/p/1754386


After I purchased a new computer, I needed to get my thumb drives working on it.

Here's the procedure:

  1. Open "Disk Utility", and look for your device, and click on it. This will let you be sure you know the correct filesystem type and device name for it. In my case, it was 'ext4' and '/dev/sdb1' respectively. Next: Decide what you want to call your thumb drive. I called mine 'USB16-C', but you choose your own name. Before closing Disk Utility, click unmount. And USER should be your login name.

    Then run steps 2 to 4 in a terminal window.

  2. sudo mkdir -p /media/USB16-C

  3. sudo mount -t ext4 -o rw /dev/sdb1 /media/USB16-C

  4. sudo chown -R USER:USER /media/USB16-C

Now my thumb drive is accessible, and it automatically connects when I reboot too.

  • This answer restricts needlessly to Ext4. And the ownership on mount points aren't stable this way (you'll have to edit /etc/fstab to do this properly). – gertvdijk Jul 15 '13 at 8:43
  • 2
    Use chmod 1777 [MOUNTPOINT] instead ot that chown, so it works for all users. The 1 is supposed to prevent other users from deleting your files. – basic6 Oct 27 '17 at 9:31

The answer below is actual only for obsolete releases. Modern releases such as 14.04 LTS and newer do not have PySDM package.

I was having a hard time solving the problem and this solution worked for me.

PySDM is a Storage Device Manager that allows full customization of hard disk mountpoints without manually access to fstab. It also allows the creation of udev rules for dynamic configuration of storage devices

  1. install physical storage device manager: sudo apt-get install pysdm
  2. open storage device manger: sudo pysdm
  3. choose your required drives
  4. press assist
  5. uncheck open as read only
  6. check owner user of file system and write your username: remon
  7. press ok
  8. press apply
  9. umount Drive
  10. mount it

Note: if you can't change files to binary executable, go to special files and check permit execution of files as binaries, and go to step 7.

  • this worked great for my issue. I have been fighting this for some time and even updating privledges from console/root didnt always help. using the app to set things up has worked since. – Kendrick Sep 2 '12 at 18:32
  • 2
    sudo apt-get install pysdm ;;; E: Unable to locate package pysdm – user391339 Dec 11 '14 at 19:14
  • @user391339 According to this answer pysdm is now obsolete and should no longer be used. – Maximillian Laumeister Aug 30 '15 at 0:13

By default, I think it mounts it as the logged in desktop user. You will want to mount instead through the "mount" command or in he fstab:

At command line:

sudo mkdir /mnt/sdd1

Edit /etc/fstab and add to the end:

/dev/sdd1 /mnt/sdd1 fuseblk defaults,umask=022 0 0

Then at the command line (to process the /etc/fstab file again):

mount -a

There are a lot of ways to do this, more intelligent ways, etc, but the long story is that you can't get the behavior you want with chmod (especially if the filesystem is a FAT filesystem that has no native concept of permissions).

If you are interested the mount man page gives a lot of information on the subject.

  • That doesnt always work even if it is true that it is mounte by the user. ubuntu has gotten confused several times on perms of my shares. I have set 774 and had the users group added to the folders and still nothing worked quite right if ubuntu automounted it. – Kendrick Sep 2 '12 at 18:34
  • Sorry, I don't understand what you are saying. The answer I gave is a correct answer (one of many possible solutions) given the question. If you are having a problem, post a new question. If you link to it here in a comment, I can help you out over there. Good luck! – dpb Sep 18 '12 at 19:21

If your external drive is portable HDD or flash drive then it is good option to edit fstab. Because it is permanent and your drive will not connect always. If you want to mount your drive with write permission then unmount your drive first (right click on drive and unmount) or:

umount '/media/Expansion Drive'

Now mount with write permission:

mount -o rw /dev/sdXY /media/External_drive

You must create the directory first:

sudo mkdir -p /media/External_drive

Hope this will help.


@VinayKrPrajapat Your solution worked but it should be specified that you should select the specific drive path not all at once as that may effect your boot up.


cd /mnt/sdc
sudo chmod -R a+rx *

Just selecting /media or /mnt would effect all drives including the boot disk which could cause problems.


Simplest one is here you only need to go to the media folder and change permissions. Follow below to commands.

cd /media/ 
sudo chmod -R a+rX *

And it's done.

  • Tried that and it just about broke my ability to boot. Can I reverse the command? – Christopher Feb 17 '17 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.