21

In Ubuntu 15.10 when using Mozilla Thunderbird with Enigmail I get the following warning (in Swedish):

Du använder GnuPG version 1.4.18, vilken inte längre stöds. Enigmail kräver GnuPG version 2.0.7 eller senare. Vänligen uppgradera din installation av GnuPG annars fungerar inte Enigmail.

As I understand it my version of GnuPG is to old and I need to upgrade. However, I can't figure out how to do that.

At Enigmail FAQ I read that:

you install GnuPG 2.0 via the regular package management system of your distribution (e.g. apt, yum, yast). On many distributions the package is called "gnupg2" or "gpg2"".

But I'm only a normal user, and I don't understand what that means and what I'm suppose to do.

I would be very happy for some help. For example some kind of very basic step by step ”How to” guide.

30

On Ubuntu, GnuPG 2.0 is available for all supported releases under the package name gnupg2 (and they are all > 2.0.7). To install it, open a terminal (press CtrlAltT) and run this command:

sudo apt-get install gnupg2

Or see How do I install software using the Ubuntu Software Center?

  • 6
    It should be noted that this does not install the gpg binary as that is still version 1. You will have to sudo apt-get remove gnupg then sudo ln -s /usr/bin/gpg2 /usr/bin/gpg – Sukima Feb 9 '18 at 18:23
  • Alternatively you might want to keep gpg available in case you run into any problems, so you can always just call gpg2 to use the new version. – Tim Malone Mar 4 '18 at 4:11
  • At least for Ubuntu 18.04, now, and for me: (1) The gnupg2 package wasn't available, (2) the command in the answer reported However the following packages replace it: gpgv gpgsm gnupg-l10n gnupg dirmngr, and (3) sudo apt-get install gpgv gpgsm gnupg-l10n gnupg dirmngr reported that all those packages were already current. Perhaps they came with my Ubuntu image. Hope it helps ... – BaldEagle Jun 24 '18 at 16:23
  • 1
    @BaldEagle yep, in 18.04 the gnupg package is GnuPG 2, and gnupg2 is a dummy package available in universe. – muru Jun 24 '18 at 16:39
  • The version in the Ubuntu repos is 2.1.11, way behind the current 2.2.8 release. This is annoying because signing commits on GitHub requires v2.1.17 or later. – Dan Dascalescu Jul 6 '18 at 2:47

protected by Community Oct 8 '18 at 16:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.