If I format a USB stick (any) on my Ubuntu 11.10 system, they are unreadable with my Windows 7 system.

I have tried both NTFS & FAT but Windows refuses to see the drive as having been formatted (it reports it as RAW in Disk Management Console).

This has been done with Disk Utility, gParted, & mkfs (mkfs.vfat / mkfs.ntfs) but nothing seems to work.

If I do this the other way (i.e. format on Windows) I can copy files to it through Ubuntu and then see them with Win7.

I'm fairly new to Ubuntu....

  • Does the USB stick work in Ubuntu after formatting in Ubuntu (including after unplugging and re-plugging it)? – JanC Nov 2 '11 at 17:07
  • It does. All files copied to it are intact.... – neildeadman Nov 3 '11 at 7:55
  • Did you try formatting using another Ubuntu/linux version? (You should be able to do that from any live-CD if you want.) – JanC Nov 5 '11 at 20:03

Open up Disk Utility, insert your USB stick. It should list under Peripheral Devices (left side). Click on it.

On right side click unmount volume and then Format Volume (not Format Drive). If only format drive appears and Format Volume does not appear read till last.

A window pops up. In type select FAT, give a name and then hit format. It asks for confirmation, press format.

After formatting press Mount Volume again.

Go to home using the File Explorer (gui, nautilus, home button), or select the drive using unity lauch bar. See if you can create new file or directory. Right click on a blank area inside file explorer (file manager) inside your drive and select properties.

If Filesystem type: says msdos. It is perfect (FAT32), it should work on windows or linux (unless you are trying to copy a file larger than 4G). 4G being limit for FAT. In Disk Utility if you don't see Partition Type: w9 FAT32 and options like Unmount Voulme or if not mounted Mount Volume, Format volume, Check Filesystem, Edit Partition, Delete Partition read on. These options should be shown in lower half below Volumes(thick black above your driver partition gui).

If you only see buttons above Volumes like Format, Safe Removal and Benchmark you have only Formatted the Drive but not created a Volume. You have to create a filesystem in a drive before you can use it.

These all steps seems lame, but if you have missed anything, it might help, if not your USB stick is damaged, get a new one.

Warning: Don't just vaguely format drives under Local Storage (you might have no os to boot into).

  • Thanks, will try this when I'm next with my Ubuntu box. USB Stick certainly not damaged as formatting in Win7 works fine on both. Will let you know how it goes! – neildeadman Dec 15 '11 at 18:20

@neildeadman - when you format the USB stick in Ubuntu as a device, let's presume you are doing this through a single tool like perhaps gparted for ease of discussion's sake. One the device has been formatted, how do you remove the device from the system prior to readying it for use within a Windows 7 system?

If you simply unplug the device, it may appear as RAW, because it has not been properly unmounted from the Ubuntu system. Would suggest unmounting the USB stick from Ubuntu prior to attempting to unplug, then remove from the Ubuntu system and then plug into the Windows 7 system and determine if the formatting remains.

The act of not unmounting the USB stick could be the potential cause for your error.

HTH. Have a nice day. :)

  • I usually either click 'Safely Remove Device' if in Device Utility or I run 'sync' and then 'eject \dev\sdc' from the command line. – neildeadman Nov 3 '11 at 7:54
  • That is odd indeed. Never seen that issue before; do you have the ntfs-3g package installed? That might help. – freecode Nov 3 '11 at 13:20
  • Not sure ntfs-3g would help as I have also tried as a FAT32 type too :S – neildeadman Nov 3 '11 at 13:59
  • Just a generic USB device? Have you tried using gnome-format with the device? You will probably have to add the package using apt-get (sudo apt-get install gnome-format) if it is in the Oneiric distribution (sorry working on Natty @ the office, Oneiric @ home - headed there later). It will offer to format in either FAT or EXT2, but should be able to format for compatibility with all devices. If that works, then pick a tool and try to format with that again and determine if the tool creates issues again. Might need to gather /var/log/syslog output to see if errors are reported. – freecode Nov 3 '11 at 17:49

when you format the usb stick, change the file format to FAT or FAT32

When formating make sure that the "take the ownership of file system" is selected

  • He tried that, 'I have tried both NTFS & FAT...' from the second sentence. – Tom Brossman Feb 16 '12 at 5:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.