0

I finally decided to give my windows 10 a boot and switch to Linux. So, I created a bootable Usb drive with pendrivelinux, wiped out my Windows and installed Ubuntu 14.04 from Usb. The installation process worked like a charm and at first everything looked ok, until I attempted to connect to net. The connection seems to be established, AFAIK. If I set one terminal to ping Google (or some other address) it will respond as long as I don't make any http requests. When I make a http requests (browser, wget, etc) the network manager seems to go haywire and further ping will fail with a message "Destination host unreachable". When I restart network manager service, http works for a few kilos or seconds. I already tested Ubuntu 15 and Linux mint, but they suffer from the same problem.

The thing is that I have no clue how to even start to fix this issue. I googled around and noticed that there was (is?) a pesky problem with libnl. Someone suggested that in this case one should try to downgrade it, but this didn't fix the problem.

I tried to change MTU values for the connection from auto to hardcoded values, as suggested, but this prevented me to connect at all. Also, the suggested solution addressed an issue between wireless and wired connection.

I don't want to revert back to Windows!

0

I couldn't find a reason for this behaviour or the root cause for it. I installed pci-e network adapter and everything is working just fine. I guess there's some sort of voodoo baked into the embedded adapter which comes with HP motherboards. Case closed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.