5

I recently installed virtualbox Ubuntu on host Windows. I am new to Ubuntu and virtualbox. I made two changes and I would like help to understand which one (and why) it messed up Ubuntu.

  1. I had downloaded an email attachment file 5MB large. I kept getting an error that the disk space was running low. I allocated storage 8GB at start (dont know where it has gone!)
  2. The screen resolution was like 640X480, so I adjusted the virtualbox-guest-dkms option, and it got fixed.

I restarted the guest session to effect the changes of the sizing. Now I am getting a pixelated screen for the login.

enter image description here

When I enter the password, I am able to get into the machine. I know this because the screen pixels change to what the desktop must be looking like.

marked as duplicate by karel, Eric Carvalho, Fabby, Zanna, waltinator Dec 29 '17 at 18:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Two remarks: 1. when creating dynamically growing virtual disks there is no point in making them so small that we risk to run out of space 2. graphics including screen resolution is done by installing guest additions to the guest OS. – Takkat Mar 19 '16 at 15:28
0

I have had a similar issue with my Ubuntu 16.04 guest installation, I received this advice:

Disable 3D acceleration until you get the guest installed and have also installed the guest additions ( in the guest ). Then do a full power down of the guest, enable 3D acceleration and see it that helps.

Taken from the answer I got when posting my issue here: Link to Virtualbox Forum Thread

Perhaps your issue has to do with 3D acceleration too, try turning it off?

1

There is a possible solution listed here that might help with a messed-up screen like that.

Press Hostkey+F1, then Hostkey+F7. The first will switch to a terminal, and the second will switch back to the desktop. Apparently, that forces some sort of redetection of the graphics setup.

(Hostkey is the right Ctrl by default.)

(Make sure the keyboard is captured.)

I also had to reboot the VM after that, for some reason.

  • This helps. With an Ubuntu 18.04 or 18.10 Guest, you need to use <CTRL>-<HOST-KEY>-<F2> followed by <CTRL>-<HOST-KEY>-<F1>. – PJ Singh Oct 8 '18 at 23:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.