2

This might be a basic reason, but somehow I have not been able to achieve it.

I am running a guest Kubuntu OS on a windows one, and I am trying to share a folder between OSes. The VMware tools have been installed properly, VM -> Settings -> Options -> Share Folders is set properly, and my windows folder is shared.

Any idea what else could prevent the hgfs folder to appear?

4

Solution Copied from Peretz:

In a previous attempt, I installed open-vm-dkms. This was preventing the hgfs file to appear.

sudo apt-get purge open-vm-dkms

and reintalling vmware tools solved the conflict.

0
3

For some reason, the auto-installed VMWare tools didn't do the job, but Ubuntu has a tool called vmware-hgfsmounter, if I installed it then I could do this:

sudo apt-get install open-vm-tools  
sudo mkdir /mnt/hgfs  
sudo mount -t vmhgfs .host:/ /mnt/hgfs  

After running these commands, /mnt/hgfs should now contain your shares.

source

1
  • Worked for me, but I had to replace vmhgfs with fuse.vmhgfs-fuse on Ubuntu 18 / VMware Fusion 8. – Form Feb 6 '20 at 22:08
1

In ubuntu 19 this worked (after changing the cdrom to IDE)

sudo apt-get install open-vm-tools sudo apt-get install open-vm-tools-desktop sudo mkdir /mnt/hgfs sudo /usr/bin/vmhgfs-fuse .host:/ /mnt/hgfs -o subtype=vmhgfs-fuse,allow_other

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.