0

Hello Ubuntu community I was trying to format my SD card so that it would be usable in any device. As I did so the windows disappeared and nothing to acknowledge if the process was already done or not. So I unplugged the SD card and an error came out stating something like the formatting process has failed. I tried to reboot the system with the SD card in but still no sign of life. What can I do to have that SD card back to life? Please help me.

1
  1. insert the sd card and then open disks application from here:

as shown in this image then

  1. select your sdcard and press ctrl+f :

as shown here by pressing ctrl+f your sd card gets formatted.

  1. after formatting then go to edit partition option and create a new partition for your sd card. then you are done.
0

This happened to me once.

Eject and reinsert the SD card, then try to format it again. If your file browser doesn't find it, try formatting it in GParted.

That worked for me, but I'm not sure if it's reproducible.

  • Please tell me more about that GParted. – isaac ibara Mar 19 '16 at 5:16
  • GParted is a FOSS formatting utility which is in standard Ubuntu repositories, and probably installed on your machine. It requires sudo and a lot of caution (you can wipe /dev/sda without care) but it can fix all partitioning and formatting issues. – user520460 Mar 19 '16 at 6:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.