3

I have a fairly new computer that uses UEFI instead of BIOS and the windows 7 installed on it uses a GPT partition table. (I've looked thoroughly, it's GPT and not leftover GPT scraps). Now, I have a free partition where I want to install Ubuntu but it won't detect my partitions that exist there.

I ran the "Try Ubuntu without installing" option and ran this command in the terminal

sudo gdisk -l /dev/sda

and the result was MBR: protected and GPT: present

I've tried using fixparts and it didn't detect any problems so I assume it's a complete GPT table. So what would be the solution to make ubuntu installer recognize those partitions and install in it?

Do I have to repartition the drive with MBR tables?

  • Please clarify what you mean by "it won't detect my partitions that exist there." If you mean that the Ubuntu installer is showing a completely empty disk, then chances are either you've got a damaged partition table (which gdisk can diagnose with its v option) or you've got leftover RAID data on the disk, which you'll have to remove. – Rod Smith Mar 18 '16 at 12:44
  • The installer shows an unformatted disk. The partition table is not damaged and there's nothing leftover as it's a new computer and I'm replacing the OEM windows – VeeK Mar 18 '16 at 13:44
  • Even new computers may have RAID options set in their firmware and/or in Windows, which can create unwanted RAID data that confuse partitioning tools based on libparted (which is what Ubuntu's installer uses). Likewise, there could be partition table damage because of a hardware failure, bug, mistake at the factory, etc.; please check it with gdisk to be sure. You may get better information on what libparted thinks is wrong by using parted on the disk, as in sudo parted /dev/sda print. Post the complete output of that command if you need help interpreting it. – Rod Smith Mar 18 '16 at 16:14
  • Thanks for the help @RodSmith but I've already installed Ubuntu. See my answer below – VeeK Mar 19 '16 at 11:15
1

No, you don't have to and should not create an mbr related msdos partition table.
Windows is installed in EFI mode, so you have to install Ubuntu in EFI mode as well.

Boot from the Ubuntu installation media and select Try Ubuntu without installing.
Open GParted, create an ext4 partition and a swap partition from the free space.

Start the installation process - choose Something else.
Select the ext4 partition and choose / as mount point.

More comprehensive information you will find here.

1

The reason for Ubuntu not displaying GPT partitions was becuase the installer was loading in BIOS mode. To view and edit/create/delete gpt partitions on a UEFI system, ubuntu installer must be loaded in UEFI mode.

I followed the instructions on Ubuntu's Community Page and selected my USB as the UEFI version and installer displayed the partitions.

Anyone going through the same thing in the future, my bootloader didn't gave me options for selecting the uefi option in boot order in the Setup page but the direct Boot Menu did showed those options. Boot Menu opens with F12 on my Gigabyte motherboard.

  • There must be more to it than that; I've done many installs in BIOS mode to GPT disks, and partitioning tools don't care about the boot mode of the disk -- they just read the disk data and interpret it. I suspect that changing the boot mode also altered RAID settings in your firmware and/or altered the way Ubuntu interacted with those RAID settings. – Rod Smith Mar 19 '16 at 14:40
  • Nice that you figured out how to solve your problem. Please don't forget to accept the most helpful answer (can be your own own anybody else's) by clicking the round grey tick symbol on the left of it. Thanks and welcome to Ask Ubuntu. – Byte Commander Mar 19 '16 at 16:17
  • In my boot menu, I had 2 options for my USB drive: one said Kingston[Some Model Number]; other said UEFI: Kingston[Some Model Number]. If I choose my usb without UEFI, It doesn't show GPT partitions, If I choose the other, it does. That's all I understand from it. Maybe hardcore experts would know better. – VeeK Mar 21 '16 at 5:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.