1

I recently installed gnome shell to try it out.

I want to be able to switch between the 2 environments. (unity + gnome shell)

The problem is that after installing gnome shell, all new users (including guest account) are set to use gnome shell.

On the lightdm user selection screen, if I go to the desktop environment selection menu, it has (Default) next to Gnome. I want that default to be next to Ubuntu.

I managed to change that using a setting in lightdm but then the guest account would login with unity but still have all the theme/icon settings of gnome so it looked broken...

I would like to set defaults back to unity as well as all the icons, themes etc to be the unity defaults for new users.

Does anyone know where I can set all that?

  • Not being able to find an answer to this, I purged ubuntu-gnome-desktop AND ubuntu-desktop and I reinstalled first ubuntu-desktop and then gnome-shell. The first time I had installed ubuntu-gnome-desktop and that seemed to try to take over as default. Everything is now as I want it. – DimitrisCSD Mar 18 '16 at 19:53
  • You should post that as the answer, since it fix your problem. This makes it easier for other people having the same problem to fix it. – QwertyChouskie Mar 20 '16 at 20:42
  • I didn't set it as an answer as it doesn't really tell where the configuration files are located to do what I wanted. What I achieved in the end was basically to reset to defaults... – DimitrisCSD Mar 20 '16 at 23:32
  • The problem is probably that ubuntu-gnome-shell depends on ubuntu-gnome-default-settings. You can run apt show ubuntu-gnome-default-settings in the terminal and look at the package description to see what I mean. – QwertyChouskie Mar 20 '16 at 23:50
  • You are right. The mistake in the first place was that I installed gnome with 'ubuntu-gnome-desktop' instead of just 'gnome-shell'. That thought that I must have no UI and I am just installing one for the first time. I wonder if there is an equivalent 'ubuntu-desktop-defaults' that would have fixed the problem – DimitrisCSD Mar 21 '16 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.