1

This problem started today. I cannot run any programs with elevated privileges from the Unity GUI. I am in the sudo group, and all of this worked fine yesterday...Ubuntu 14.04

  • Software Center immediately closes without offering the password dialog.
  • User Manager does not allow me to unlock.
  • I can no longer mount a USB stick, as I don't have permission.

I CAN execute gksu synaptic from the command line. And I can mount the USB manually with sudo mount /dev/sdl1 /media/usb

UPDATE:

I discovered this has to do with PolicyKit. I sort of solved the problem by creating /etc/polkit-1/localauthority.conf.d/60-myauthority.conf and specifically adding my username to AdminIdentities

That still doesn't explain why PolicyKit is not honoring the sudo group in /etc/polkit-1/localauthority.conf.d/51-ubuntu-admin.conf, as I've stated I'm in the sudo group.

1

I just had exactly the same behaviour - adding the users to the authority list gives them access, but not the group.

In my case I had to reinstall the package libpolkit-gobject-1-0, which I somehow accidentially removed.

Seems that policykit needs that library to find out in which groups a user is.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.