1

I've been trying for some time to fix a mistake I have made around a month ago with Windows 8 after installing Xubuntu beside it. In order to make my laptop run GRUB2 instead of the original Windows Boot Loader I edited through command lines using bcdedit on Windows the EFI file paths of the Windows Boot Manager.

After many issues, I had to format my HDD and I could only install a Linux operating system. Windows ones could not, my laptop not even finding a boot file on the Windows recovery disk. I do believe that, since the Windows Boot Manager has different paths that it should have for loading EFI files, it cannot boot any Windows anymore. I have attempted with windows 7, 8 and 10 on disks and USB keys.

By the way, I have attempted to boot Windows disks by using VirtualBox using the physical HDD. When in non-EFI mode, the installation software runs well but refuses to install anything because of the disk's format. When in EFI mode, being my HDD's, it freezes before launching.

I have seen posts about rEFInd and boot-repair but before trying these out I'd love to know if someone could reply to the question beneath.

Is is possible to manually edit these paths from Ubuntu ? It has to be stored somewhere but I cannot seem to find where.

===============

Solution found with the help of ubfan1 :

I opened a terminal and typed the command bellow to have a list of the UEFI boot entries :

sudo efibootmgr -v

I deleted the Windows Boot Manager entry and another boot entry called "Yes" by typing :

sudo efibootmgr -B {boot_entry} for both.

I rebooted and noticed I no longer had the Windows Boot Loader. I booted into Ubuntu and added it back by typing :

sudo efibootmgr -L "Windows Boot Manager" -l "/EFI/Microsoft/Boot/bootmgfw.efi" -p 1

I then rebooted into Ubuntu and noticed the changes had been made. It was possible once again to boot Windows from any device.

  • Which version Ubuntu are you trying to install? Which kernel are you using? What model laptop? Did you set a supervisor password? – ubfan1 Mar 27 '16 at 21:41
  • I am not attempting to install Ubuntu but to edit the Windows Boot loader's EFI file paths from Ubuntu. I have Xubuntu 14.04 installed on my laptop (Packard Bell Easynote) as well as an USB key with Xubuntu 14.04 live on it. I also have a bootable Win8.1 usb key but it seems it cannot find the boot files because of the incorrect file paths. I didn't set a supervisor password. – Bryzz Mar 28 '16 at 10:03
1

efibootmgr is the program to manage the UEFI boot items and their order. The man page has full instructions.


Maybe Packard Bells have to set "trust" on your (new) efi boot files. See problems with dual boot om package bell Set secure boot, select "Select a UEFI file for trusting". You might get additional choices after you enable the supervisor password. Search this site for Packard Bell and see what you find.
Entering Windows boot entries in efibootmgr is pretty much the same as entering Ubuntu entries.

sudo efibootmgr -v  

to check what's there. A typical Windows entry looks like:

Boot0004* Windows Boot Manager  HD(2,e1800,82000,04b9edc2-fc48-11e1-8ec1-e7137b3aaf29)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...n.............

Entering a new one (-p for the EFI partition, defaults to 1)

sudo efibootmgr -L "Windows Boot Manager" -l "/EFI/Microsoft/Boot/bootmgfw.efi" -p 1

Maybe -c to create or -b to edit an existing entry, check the man pages. Maybe need the backslash \ instead of slash / for the paths.

  • I have attempted to use efibootmgr but the changes are overwritten by the default configuration at every boot of the computer, may it be about the boot order, the deletion of an item, the addition of an item, etc. The secure boot option in the BIOS was disabled when I attempted to edit the UEFI boot items. – Bryzz Mar 27 '16 at 15:31
  • I followed your suggestion along some more modifications such as deleting a boot entry called "Yes", then Windows's before re-entering the Windows boot entry. It seemed that this "Yes" boot was doing its best to keep the settings as they were for some reason I cannot get. After deleting it, I could edit the UEFI configuration with no forced rollback. Thanks a lot for your help, I shall close the question now. – Bryzz Mar 29 '16 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.