3

I have a notebook Dell Inspiron Model 14 3437-A30 and in my gtalk appears that the camera is turned on and is automatically turned on, but the light is not on. Also, unfortunately there is no keyboard shortcut.

I tried to use the cheese program, but it only activates the webcam.

I feel that my webcam is being automatically turned on without turning on the light.

How do I disable my webcam so the gtalk not show that my webcam is turned on? or how to make my webcam is not automatically activated?

7

Try to find the driver for your webcam and unload it. I don't have Dell Inspirion so I don't know what driver you have for webcam. Try to find it with

lsmod

In my case it was uvcvideo. When you find it unload it. In my case the command was:

sudo rmmod uvcvideo

After I removed it, the cheese did not find the device any more and it couldn't work. Then try to load it again. In my case the command was

sudo modprobe uvcvideo

If your driver is not uvcvideo replace it in the commands with your driver name. Make a test too to see that your application does not load the driver. It is a small possibility for that also because root privileges are required to load kernel modules.

1
  • Thank you so much for your help @nobody, was exactly that I needed! – ricardoramos Mar 18 '16 at 20:23
4

Instead of disabling the uvcvideo driver (which disables all the webcams), you can also disable one webcam and keep all the others functional. For that:

  1. Find out the device string of the webcam you want to disable:

    for device in $(ls /sys/bus/usb/devices/*/product); do 
      echo $device; cat $device; 
    done
    

    This will show result lines like this:

    /sys/bus/usb/devices/1-1.6/product
    Integrated Camera
    

    In which case the device string we look for is 1-1.6.

  2. Disable the webcam using your device string in a command like this:

    echo '1-1.6' | sudo tee /sys/bus/usb/drivers/usb/unbind
    
  3. To enable your webcam at a later time, use your device string in a command like this:

    echo '1-1.6' | sudo tee /sys/bus/usb/drivers/usb/bind
    

For more details, see: "Disabling the Webcam or USB Ports on Linux".

2

As an alternative command to rmmod you can use this to disable the camera until reboot:

sudo modprobe -r uvcvideo

And if you get the error message: modprobe: FATAL: Module uvcvideo is in use, you can try to force its removal with rmmod using the -f parameter:

sudo rmmod -f uvcvideo

To enable your webcam back again, type:

sudo modprobe uvcvideo

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.