This question already has an answer here:

I'm using Ubuntu 15.10. I need to install PHP 5.4 version cause of one of PHP plugin just support for php < 5.56 how to do this?

marked as duplicate by David Foerster, Eric Carvalho, Aaron, amc, Zanna Oct 6 '16 at 8:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


You can use the Ondrej oldstable PPA to install php 5.4. First you need to remove the existing php.

sudo apt-get remove --purge `dpkg -l | grep php | grep -w 5.5 | awk '{print $2}' | xargs`

sudo apt-get install python-software-properties

sudo add-apt-repository ppa:ondrej/php5-oldstable

sudo apt-get update

sudo apt-get install -y php5

Not the answer you're looking for? Browse other questions tagged or ask your own question.