I have a HP Pavilion dm4-2070us which has an Intel Corporation Centrino Wireless-N 1000 adapter.

The problem is that my computer doesn't show the wireless networks after I upgraded my system to Ubuntu 11.10. Following is my output for sudo lshw -class network:

*-network DISABLED      
   description: Wireless interface
   product: Centrino Wireless-N 1000
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   logical name: wlan0
   version: 00
   serial: 8c:a9:82:81:5a:30
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlagn driverversion=3.0.0-12-generic firmware= build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
   resources: irq:42 memory:c2500000-c2501fff

   description: Ethernet interface
   product: AR8151 v2.0 Gigabit Ethernet
   vendor: Atheros Communications
   physical id: 0
   bus info: pci@0000:08:00.0
   logical name: eth0
   version: c0
   serial: 2c:41:38:07:f3:e3
   size: 100Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion= duplex=full firmware=N/A ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
   resources: irq:44 memory:c1400000-c143ffff ioport:2000(size=128)

The output for rfkill list all:

0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hp-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hp-wwan: Wireless WAN
    Soft blocked: no
    Hard blocked: no

I have also searched about the status of the WiFi network being shown as disabled. Somehow everything pointed to the fact that my wireless device is switched off and it can be switched on from Windows only. However, I don't have windows partition and it has just Ubuntu 11.10 so I don't see any point in switching the device on in Windows.

  • Also when I click on top right corner of the screen on the available network icon, it shows that the wireless devices are not ready yet!! Previously to Ubuntu 11.10 I had Ubuntu 11.04! and everything was working fine in that though at that time I had a dual bootable system. – new_bie Nov 2 '11 at 15:52
  • ok one more thing....my friend has a lenovo laptop...he has the same wireless card...and he's using 11.10 and he isn't facing any problems with his wireless card. – new_bie Nov 2 '11 at 16:20
  • is the difference that your friend installed 32bit 11.10 and you have 64bit? – fossfreedom Nov 2 '11 at 16:27
  • no..even he has a 64-bit ubuntu 11.10..!!! This problem is not vendor specific as we both have the same centrino wireless card...!! moreover my wifi was working correctly when I had 11.04..!! – new_bie Nov 2 '11 at 20:26

After trying out different distributions and struggling with my wireless card I finally stumbled upon a link that gives a work around to the problem. Apparently the new kernel fails to detect the Centrino 1000 N wireless card in some laptops(hp dm4) while there are other laptops on which it works completely fine like Lenovo Y560P.

The following link gives the solution!! Even though I am not sure whether this work around will have any greater impacts later or not, but for now its working fine.


"To (temporarily) get the wireless working on newer kernels:

sudo mv /lib/firmware/iwlwifi-1000-5.ucode /lib/firmware/iwlwifi-1000-5.ucode.backup
sudo modprobe -r iwlagn
sudo modprobe iwlagn

This should make the wireless use the old 1000-3.ucode which works at the moment."

| improve this answer | |
  • Please note exactly same issue still exists for me with my Acer 1810-TZ with a Intel wireless N-1000 wifi card. BUT Ubuntu 12.04 NO LONGER ships with the older version 3 of the intel firmware - I ended up getting it out of an older Ubuntu distro I had to hand. – Maks May 2 '12 at 4:11
  • @Maks Do you mean that you got the older version microcode from someother distribution? I tried getting it from Intel's website intellinuxwireless.org/?n=downloads&f=ucodes_1000 and copying it in the path /lib/firmware. But it didn't work out. Am I missing something here? – new_bie May 3 '12 at 8:22
  • Sorry that was my mistake, using the older version of the microcode did not actually fix it for me, what did was disabling 802.11 N, I've updated my answer to the other question to reflect this. – Maks May 3 '12 at 13:16

None of the solutions above worked for me I had to pass the mod option below

options iwlwifi bt_coex_active=0 

I picked this up from intel forum that I can't find the link to right now.

| improve this answer | |

I tried:

echo 'options iwlagn 11n_disable=1' | sudo tee /etc/modprobe.d/iwlagn.conf >/dev/null

and it's working.

| improve this answer | |

Well the better solution is to have either the firmware fixed or more likely the driver fixed to work correctly with the version 5 of the firmware.

Seems this has been reported "upstream" in intels bug tracker.

But so far there is no better solution than to replace the version 5 firmware with older version 3.

I'm going to monitor the bug in the tracker and update my answer here once they do come up with a better solution.


Turns out I was mistaken - using the older version 3 of the microcode (ucode) firmware does NOT solve the issue for me. What I've confirmed does work in my case at least is using the version 5 ucode (as shipped in 12.04) but re-loading the driver with "N" disabled:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1

as per an answer in this forum thread.

| improve this answer | |
  • I tried the commands as mentioned in the following link: link but the problem persists. Also I tried downloading the microcode images from Intel's website link and I copied the microcode in the path accordingly. But even that didn't work. Am I missing something here?? – new_bie May 3 '12 at 8:05
  • ummm... you've accepted the answer - I presume this has been resolved by this answer? – fossfreedom May 3 '12 at 11:04
  • I updated my answer with more information since I discovered that switching to the older firmware do not in fact actually work for me. THe real resolution to this of course is to get the intel kernel driver guys or some other helpful kernel dev to come up with an actual fix to this issue and have ubuntu ship the updated driver. – Maks May 3 '12 at 12:59
  • I tried everything you mentioned but its not working.Can my hardware be at fault? and I posted my output for lshw -class network. wireless section is shown as UNCLAIMED!! – new_bie May 3 '12 at 21:01
  • I just checked on my laptop and no, I don't have UNCLAIMED next time the entry for the N 1000. Could you post the output of your dmesg | grep iwl ? that may have some useful info about whats happening when the ucode is being loaded by the driver. – Maks May 4 '12 at 0:23

I also had issues with this and tried many of the suggestions that were here and scattered about the internet with no success.

I found the command inxi -N very helpful in determining exactly what wireless card I was using.

Ultimately the fix was to copy drivers downloaded from Intel website http://wireless.kernel.org/en/users/Drivers/iwlwifi to /lib/firmware upon rebooting wireless worked flawlessly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.