2

When my laptop goes to suspend, a slight mouse movement wakes my laptop up. This is bad when I am packing my pc into my bag and accidentally move my mouse. PC stays up during the ride consuming battery. So there is already this topic but it did not help: previously asked question

I made sure all usb devices are disabled to wake up:

Device  S-state   Status   Sysfs node
LID   S4    *enabled 
SLPB      S3    *enabled 
IGBE      S4    *disabled  pci:0000:00:19.0
EXP2      S4    *disabled  pci:0000:00:1c.1
XHCI      S3    *disabled  pci:0000:00:14.0
EHC1      S3    *disabled  pci:0000:00:1d.0

by echoing to the /proc/acpi/wakeup the device names EHC1 and XHCI in /etc/rc.local

Also I have identified the device with lsusb and made sure

cat /sys/bus/usb/devices/2-6/power/wakeup

returned disabled.

I don't know how else I can disable it. I am using Lenovo T450s with Ubuntu 14.04 LTS.

Thanks!

Edit: I am using Fujitsu wireless mouse WI610.

  • Can't you turn off the mouse when not using it? Or, if it has a USB receiver, remove that before moving. Not very high tech, but it is what it is. – Marty Fried Mar 16 '16 at 23:55
  • duplicate of askubuntu.com/questions/252743/… – Scott Stensland Mar 17 '16 at 2:40
  • Ah, sorry, retracted my vote. – Jacob Vlijm Mar 17 '16 at 5:22
  • Thanks Marty, yes that is a workaround. But this in 2016 with Ubuntu 14.04 LTS this should not be any issue! Besides, very often I forget to remove the tiny USB wireless dongle from my laptop, especially when I am in hurry. – Genom Mar 17 '16 at 10:14
  • Hi @ScottStensland , I have already mentioned that question. But none of the solutions there helped me. – Genom Mar 17 '16 at 13:46
1

On my Ubuntu 16.04 x64 ASUS ZenBook UX430UA works the following:

# Check
more /proc/acpi/wakeup
or
grep --color -E '|enabled'  /sys/bus/usb/devices/*/power/wakeup

and then disable routine

# Disable
for f in /sys/bus/usb/devices/*/power/wakeup
do
   echo "disabled" > $f
done

In order to disable after reboot, add disable routine into /etc/rc.local before exit 0 line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.