0

I wish to transfer files between a Windows 10 desktop and a media server running Ubuntu 14.04.1. I have Samba installed on Ubuntu and I can transfer files only wirelessly. The Windows 10 desktop has a wireless USB dongle, which connects to my 4G mobile-broadband device (EE Osprey). The media server has a PCI express wireless adapter, which also connects to the 4G mobile-broadband device. File transfer is only possible in this configuration.

However, when I remove the wireless USB dongle from the Windows 10 desktop and connect to Ubuntu directly using an ethernet cable, Windows 10 fails to detect my Ubuntu shared folder. I even tried to connect the Windows 10 desktop to the Ubuntu media server via a desktop switch (i.e. using Windows 10 desktop to desktop switch using an eternet cable, Ubuntu media server to same desktop switch using another ethernet cable) and this doesn't work. Windows 10 can't seem to detect the Ubuntu media server in this configuration.

Please note that during all this time, I have removed the wireless USB dongle from the Windows 10 desktop but the Ubuntu media server has the PCI express wireless adapter on at all times.

Could anybody help me with this situation please? How can I connect the two computers using only ethernet / LAN and not wireless?

Thank you.

0

1) You might need a crossover cable. (Not likely, as most modern NICs automatically crossover)

2) You must manually assign IPs since there is no DHCP server involved when connecting directly.

If you need help assigning IPs, I'll be more than happy to extrapolate. (I don't know your level of networking know-how)


How to assign IPs

First, let me make sure I completely understand what you are trying to do. When connected, your computers would look like this, correct?


enter image description here


On your Windows 10 computer:

Go Control Panel > Network & Sharing > Change Adapter Settings (in the left pane)

Once there, right-click on your Ethernet NIC and select "Properties".

In the Properties menu, select IPv4 and click properties (See screenshot) enter image description here

After doing that you should be presented with this dialog box (your values will be different of course):
enter image description here

Change the following:
1) Change the top radio button to "Use the following IP address"
2) Change the IP address to 192.168.4.12
3) Change the "subnet mask" to 255.255.255.0
4) Leave the "default gateway" blank
5) Change the bottom radio button to "use the following DNS server addresses"
6) Make both DNS boxes blank
7) Uncheck "validate settings upon exit"


On your Ubuntu computer:
Go Dash > Network Connections

Then, click on "Wired Connection 1" and click edit in the right pane. After it pops up, switch to the IPv4 Settings tab.

Then in the mode drop-down, select Manual: enter image description here

In the addresses area, click add on the right side.

Change the following:
1) IP address to 192.168.4.13
2) Subnet Mask to 255.255.255.0
3) Leave Gateway blank

Then, click save.

Restart both machines. Your IPs are now assigned!

  • I would greatly appreciate help assigning IPs please. Thanks. My level of networking know-how is pretty poor. – Mochaccino Mar 20 '16 at 9:43
  • @Mochaccino No problem! Tomorrow, I'll update my answer with screenshots and directions on how to assign the IPs. – Android Dev Mar 21 '16 at 1:30
  • @Mochaccino - See edited answer – Android Dev Mar 21 '16 at 21:45
  • Many thanks. This has now worked. I found out that the problem was that the Ubuntu server already had a static IP configured to a previous older router (using VI editor). I managed to delete this first. Do I have to do anything to mark this question as solved? – Mochaccino Mar 26 '16 at 21:17
  • @Mochaccino - You already took the necessary steps to do so :) – Android Dev Mar 27 '16 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.