0

I have been trying to install mariadb on Ubuntu 14.04

I installed it some 4 months back, following a tutorial from mariadb website.

I typed the following commands :

sudo apt-get install software-properties-common
sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xcbcb082a1bb943db
sudo add-apt-repository 'deb [arch=amd64,i386] http://mirror.netinch.com/pub/mariadb/repo/10.1/ubuntu trusty main'
sudo apt-get update
sudo apt-get install mariadb-server

And the installation failed leaving my system in a mess.

When I try to install libmariadbclient-dev I get the following errors:

sudo apt-get install libmariadbclient-dev 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  libmariadbclient-dev
0 upgraded, 1 newly installed, 0 to remove and 214 not upgraded.
1 not fully installed or removed.
Need to get 0 B/1,279 kB of archives.
After this operation, 7,362 kB of additional disk space will be used.
(Reading database ... 286477 files and directories currently installed.)
Preparing to unpack .../libmariadbclient-dev_5.5.47-1ubuntu0.14.04.1_amd64.deb ...
Unpacking libmariadbclient-dev (5.5.47-1ubuntu0.14.04.1) ...
dpkg: error processing archive /var/cache/apt/archives/libmariadbclient-dev_5.5.47-1ubuntu0.14.04.1_amd64.deb (--unpack):
 trying to overwrite '/usr/share/aclocal/mysql.m4', which is also in package mysql-common 5.7.11-1ubuntu14.04
Errors were encountered while processing:
 /var/cache/apt/archives/libmariadbclient-dev_5.5.47-1ubuntu0.14.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have also tried sudo apt-get install -f as suggested in many posts but to no avail. I have also tried suggestions in how-to-install-mariadb-on-ubuntu-14-10

  • There's an implicit conflict between mysql-common and libmariadbclient-dev . Do you really need the latter? *-dev packages are not necessary to run software from packages. If you need it, try to remove mysql-common first. If you want help with the installation of mariadb-server you need to include the verbatim output of apt-get so people can see the issue and help you. – David Foerster Apr 25 '16 at 18:57
  • @DavidFoerster Thanks for your suggestions. Though coming late as I had already resolved the issue. – bwepngong Apr 30 '16 at 12:05
-2

Change the order of your commands. First do

sudo apt-get update

then followed by rest of your commands

  • 1
    -1 This won't help with conflicting packages. – David Foerster Apr 25 '16 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.