2

I have read other posts, most of them were not solved, and I also tried the "solutions" posted there.

I wasn't successful getting a download link by the terminal apt-get install --print-uris build-essential

I wasn't successful with sudo apt-get install build-essential neither. I have found an .RPM version of build-essential here. though the steps are not working for me.

2ND question. ----I even tried https://community.linuxmint.com/software/view/build-essential to download directly by AptURL but when I open it, it says "Package build-essential is virtual" What does that mean? Or should I say, how would I resolve it?

0

The package build-essential is essentially an "Informational list of build-essential packages" rather than an actual package, hence the 'virtual' tag. The details of the most 'essential' of these files can be seen here for Trusty Tahr.

A start, if for whatever reason you cannot install the actual 'build-essential' package, would be to run:

sudo apt-get install dpkg-dev g++ gcc libc6-dev make

And this would provide at least a start for compiling applications...

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.