10

I am attempting to install the latest version of wxwidgets via the terminal and followed these directions.

However, when I navigated to the folder /usr/include, a folder was created called wx-3.0-unofficial. Is this the correct folder?

Also, if I wanted to install v3.10.0, would I perform the same commands but replace 3.0 with 3.1?

Basically, are these the correct commands I should use to install wxwidgets or is there a better method?

On the page, the commands are as follows (I skipped the part on installing the IDE):

sudo apt-add-repository 'deb http://repos.codelite.org/wx3.0.2/ubuntu/ trusty universe'
apt-get update 
apt-get install libwxbase3.0-0-unofficial \
                libwxbase3.0-dev \
                libwxgtk3.0-0-unofficial \
                libwxgtk3.0-dev \
                wx3.0-headers \
                wx-common \
                libwxbase3.0-dbg \
                libwxgtk3.0-dbg \
                wx3.0-i18n \
                wx3.0-examples \
                wx3.0-doc

Then, I followed some directions from the user guide

cd /usr/include
ls | grep wx
sudo ln -sv wx-2.8/wx wx

I replaced 2.8 with 3.0

4

After waiting for some time, wxwidgets has posted a little tutorial on how to install the latest version. As of this writing, the latest is v3.1.0. The tutorial can be found here:

http://codelite.org/LiteEditor/WxWidgets31Binaries#toc2

In a terminal, do something like:

sudo apt-add-repository 'deb http://repos.codelite.org/wx3.1.0/ubuntu/ artful universe'

For artful, substitute your distribution, such as xenial for ubuntu 16.04.

sudo apt-get update  
sudo apt-get install libwxbase3.1-0-unofficial \  
                     libwxbase3.1-dev \  
                     libwxgtk3.1-0-unofficial \  
                     libwxgtk3.1-dev \  
                     wx3.1-headers \  
                     wx-common \  
                     libwxgtk-webview3.1-0-unofficial \  
                     libwxgtk-webview3.1-dev \  
                     libwxgtk-media3.1-0-unofficial \  
                     libwxgtk-media3.1-dev \  
                     libwxbase3.1-0-unofficial-dbg \  
                     libwxgtk3.1-0-unofficial-dbg \  
                     libwxgtk-webview3.1-0-unofficial-dbg \  
                     libwxgtk-media3.1-0-unofficial-dbg \  
                     wx3.1-i18n \  
                     wx3.1-examples

wx-common and wx3.1-i18n are optional packages and will conflict with the distro's wx2.8 equivalents. That is unlikely to matter too much, but wx-common contains wxrc, so if you use this be aware that there may be differences after upgrading.

Edit:

For a one line command:

sudo apt-get install libwxbase3.1-0-unofficial && sudo apt-get install libwxbase3.1-dev && sudo apt-get install libwxgtk3.1-0-unofficial && sudo apt-get install libwxgtk3.1-dev && sudo apt-get install wx3.1-headers && sudo apt-get install wx-common && sudo apt-get install libwxgtk-webview3.1-0-unofficial && sudo apt-get install libwxgtk-webview3.1-dev && sudo apt-get install libwxgtk-media3.1-0-unofficial && sudo apt-get install libwxgtk-media3.1-dev && sudo apt-get install libwxbase3.1-0-unofficial-dbg && sudo apt-get install libwxgtk-webview3.1-0-unofficial-dbg && sudo apt-get install libwxgtk-media3.1-0-unofficial-dbg && sudo apt-get install wx3.1-i18n && sudo apt-get install wx3.1-examples
2

Did you look at wxWidget guide.

Following the developer guides is always the best way to install something.

  • 3
    Yes, I did look at this guide; however, it refers to an out dated version. I am looking to install the latest. Unless I replace the 2.8 with 3.1 or 3.0? – philm Mar 15 '16 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.