As soon as I hooked the printer into the computer, Ubuntu said that it was installed. So, I tried printing, and a paper prints saying "** Unable to open the initial device, quitting."

Then I run a diagnostic on the printer, and it comes up with nothing, except for a troubleshoot document, in which I don't understand at all. (Will post results if asked, they're just extremely long).

The next thing I do is Google it, and I find a link to download and install the drivers for it, so I follow the instructions: http://hplipopensource.com/hplip-web/install/install/index.html

I type what's in the first step, then hit enter.

Instead of saying what it's suppose to (in the 2nd picture on the link), it says: "sh: Can't open hplip-3.11.10.run". That's all it says. I need help! Any suggestions would be extremely appreciated!


I changed the driver from the default (hpijs) to the next one in the list of drivers that came with Ubuntu, which was CUPS + Gutenprint simplified, and it started working just fine.

Thanks for all your help!

| improve this answer | |

I'd recommend sticking to following the instructions from HP's website. However, as for the error that you're receiving that's very odd. Did you make sure you marked the .run file as an executable (right click > properties > allow file to be run as executible)? You might also want to try it with the sudo command.

I've had plenty of troubles installing HP Printers before.. Are you sure that printer isn't one of the preconfigured (drivers already installed) in Ubuntu?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.