2

I'm using Xubuntu 15.10 on my GA-C847N motherboard.

I can set appropriate resolution using the following command:

sudo xrandr -s 1440x900

However, each time after machine is rebooted I'm getting some weird distorted resolution and I need to change it manually again. During this time I can't open the Display Settings dialogue, the window of this dialogue is black and it crashes.

I'm experiencing this problem after switching to the old monitor Acer AL1916W connected via VGA interface.

Before that I was using a newer monitor via HDMI and it worked flawlessly.

What could be the reason for this? How do I preserve the resolution. Maybe I need to pre-generate the xorg.conf file? How do I do that for my configuration?

I used to have NVIDIA descrete graphic adapters and I'm not familiar with embedded ones.

5
  • At the expense of sounding unhelpful .... just dont use the VGA monitor. Your system works connected via HDMI. I try hard not to give answers like this usually but wonder if you need to bother with this. That said, boot into a live 14.04 environment and see if that works for starters. I stopped using non LTS releases a while a go as I always seemed to hit issues just like this one. – hatterman Mar 15 '16 at 5:38
  • Sadly, this monitor only has one VGA input port. No way to use HDMI with it. And thanks for the LTS hint, I will consider it. However, I will prefer to solve this problem nevertheless. In the end current workaround is a better option than reinstalling the whole system again = ) – Slava Fomin II Mar 15 '16 at 5:42
  • You lose nothing by booting into a live 14.04LTS disc, dont install it just run it. It will not touch your installed system. If the VGA works properly it might be food for thought. – hatterman Mar 15 '16 at 5:47
  • Yeah I know. I just can't see how it will help me to solve the issue with my current system though = ) – Slava Fomin II Mar 15 '16 at 5:57
  • Because you will then know it is a 15.10 issue (or not), and can then decide whether all you can do is use a workaround. Good luck :) – hatterman Mar 15 '16 at 6:04
1

If local screen settings are not "surviving" a reboot or re- log in, your issue is almost certainly the result of a bug. For that reason, it is very hard, if possible at all, to solve without a workaround, since the issue occurs locally, and possible global settings are simply overruled with incorrect local settings.

To solve (workaround) the issue, we need to (re-) confirm our own settings on log in, by adding a command to Startup Applications.

What to do

If your screen is set correctly when using the command

xrandr -s 1440x900

(no need for sudo), just add the following to Startup Applications: Dash > Startup Applications > Add. Add the command:

/bin/bash -c "sleep 10 && xrandr -s 1440x900"

It is a workaround, but it works. The sleep 10 is needed to make sure the screen setting will not be overruled by local procedures on log in. ten seconds after log in, your screen will be set correctly automatically.

Possibly you need to play a bit with the 10 seconds.

To make it work for all users

  1. Create a .desktop file:

    [Desktop Entry]
    Name=set_screen
    Exec=/bin/bash -c "sleep 10 && xrandr -s 1440x900"
    Type=Application
    

    save it as set_screen.desktop

  2. Copy the file into /etc/xdg/autostart

Now the command will run for all users during log in.

8
  • That's a clever automation, I was going to use something like this until I will manage to fix the problem. Thanks! But is there a way to run this code for all users of the OS? ) – Slava Fomin II Mar 15 '16 at 6:02
  • @SlavaFominII Absolutely, will edit in a minute. – Jacob Vlijm Mar 15 '16 at 6:03
  • Also, I think there should be a way to pre-generate the xorg.conf file and put this configuration option into it. However, I wasn't being able to find the way to do it. Do you have experience with it? ) – Slava Fomin II Mar 15 '16 at 6:05
  • @SlavaFominII the problem is that it is a bug, (locally) overruling the screen setting on log in. Very hard to find out, if possible at all. See my latest edit. – Jacob Vlijm Mar 15 '16 at 6:13
  • This is a pretty good workaround, I think I can live with it for now. Thanks, for helping me out ; ) – Slava Fomin II Mar 15 '16 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.