1

This question already has an answer here:

I just finished setting up a dual boot with Ubuntu and Windows 10 on my HP G6, and I ran into a really frustrating problem. Ever since I finished the install, my screen goes black right after I choose Ubuntu and it finishes loading. I can bypass by changing around the quick splash in grub. Or by opening in recovery and them proceeding to launch normally.

I assume it has something to do with my drivers but they're all active in additional drivers. So it's probably something I need to either change in grub that will stay permanently or find a driver update online.

I'm really new to Linux so any help is really appreciated. Very excited to get into this OS and have some fun. Thanks.

marked as duplicate by Eric Carvalho, Pilot6, kos, David Foerster, Luís de Sousa Mar 22 '16 at 14:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • This exact issue seems to be a reoccurring theme today... Maybe an incompatibility with Windows 10? – Android Dev Mar 15 '16 at 1:29
  • Weird. Well I would think that but I'm pretty sure it's just graphic related because I can hear Ubuntu noise in background, like the screen is the only thing not working. But of course I'm probably wrong and it's something more serious. I just hope not. – Walt Mar 15 '16 at 1:51
  • What happens if when you are on the back screen, you switch to the terminal (CTRL + ALT + F1) and then switch back to the desktop? (CTRL + ALT + F7) – Android Dev Mar 15 '16 at 2:06
  • Just tried it. Nothing. I can hear the sound as I keep hitting escape so I know it's open. Damn. Thanks though – Walt Mar 15 '16 at 2:14
  • And I know the operating system is working, I just pressed my power button quickly to bring up the shutdown window and hit enter and it went through the process normally and my computer shutdown. So everything is working I just can't see it. – Walt Mar 15 '16 at 2:20
2

First, boot to recovery mode and drop to a root shell.

1) Mount the file system as R/W: mount -o remount,rw /

2) Next, run sudo nano /etc/default/grub

3) Then add nomodeset to GRUB_CMDLINE_LINUX_DEFAULT:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Becomes:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

And then save by hitting Ctrl+O, then exit nano with Ctrl+X

4) Finally, run:

sudo update-grub
sudo reboot
  • Ok I'm there and added nomodeset. Hit ctrl O to save. It takes me to bottom and says File Name to Write: /etc/default/grub I then hit enter and it says read only file system. I'm not sure how to get back out of it. Ok never mind I think I've got it. Trying now – Walt Mar 15 '16 at 3:57
  • It wouldn't let me do the sudo update part at end. Said was read only. So I rebooted and it didn't work. I probably did something wrong I guess. Thanks for that. I think that's what I need to do. If I can do correctly. – Walt Mar 15 '16 at 4:05
  • @Walt I have added a step that remounts the filesystem as R/W. – Android Dev Mar 15 '16 at 11:07
  • Dude... Dude! Thank you! Ha. As of a week and a half ago I didn't even know what a Linux was and now I'm WarGames'n it up 😉 Can't wait to really get into it now. But expect more from me I'm sure 😊 Thanks to everyone that responded. – Walt Mar 15 '16 at 17:00
  • @Walt - If it worked, please mark my post as answer :) – Android Dev Mar 15 '16 at 17:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.