0

I bought this new laptop and there are tons of problems in installing ubuntu. There is a not full solution here:

Dual Boot on Dell Inspiron 7559 laptop

It doesn't work for me cause I ended up where I cannot do what the solution says. Let me start from the beginning.

I used a USB stick with the latest version (ubuntu-15.10-desktop-amd64.iso) and after many tries I could install ubuntu.

I don't know why but the loading screen and the passages through installation went through smoothly all of a sudden, till the really end when I had to reboot manually cause i couldn't move the mouse and click "Restart Now". What ever.. The installation left 500Gb to windows 10 and created a new partition of 500Gb for ubuntu. I tried to boot the new installed Ubuntu but nothing: black screen. I booted in recovery mode and I went to driver settings and I set nVidia ones instead of the wrong ones. So finally when I rebooted Ubuntu normally it worked. I installed some stuff and did full updates of the system then I shutted down ubuntu. After using Windows 10 a bit I booted again ubuntu it gave me the following error:

kernel panic-not syncing: VFS: unable to mount root fs on unknown block(0,0)

Ok then I looked it up and I found out I had to start ubuntu from liveUSB and run some commands like:

sudo mount /dev/sda1 /mnt
sudo grub-install --root-directory=/mnt /dev/sda

The problem is I cannot anymore! liveUSB doesn't start as it get stucked in ubuntu loading screen! The laptop doesn't even have a cd reader I can only use USB! The recovery mode of ubuntu gives kernel problem as well. The BIOS setup is already changed to:

Secure Boot = [Disabled]
Load Legacy Option Rom = [Disabled]

Also I tried in grub panel pressing 'e' to write nomodeset at the end of linux line. I did it everywhere (installed grub panel and the liveUSB one) hoping that was allowing me to boot something but it never worked. Please read the answer in the old thread to have a full picture. How do I do what they say here if I have no access at all to the prompt? Dual Boot on Dell Inspiron 7559 laptop

Should I go on Windows 10, delete ubuntu partition and start over?

1

Might not be the right answer for you, but: I have same laptop and I bought M.2 SSD, installed Windows there and then installed Xubuntu on the HDD, with bootloader installed on HDD (/dev/sdb) Xubuntu works just fine. Samsung or Crucial M.2 2280 models are quite cheap nowadays and the performance is worth to buy it. Anyway if you want to use your Ubuntu primarily you can still install it on SSD (don't forget to select your bootloader on the correct drive) and leave Windows on HDD :)

  • it sounds smart but it still sounds awful I need to do all that just to have ubuntu! honestly it might even not work since it didnt look like it was just an incompatibility of the HDD but more of the whole system, BIOS, what ever – paolotamag Apr 11 '16 at 22:01
1

Let me share my experience with Dell Inspiron 7559 + Windows 10.

First I had Windows 10 GPT (UEFI) preinstalled. Had the same splash screen freezing problem. Overcame it by specifying acpi=off kernel parameter (same as you did with nomodeset, but that didn't work for me, whereas acpi=off worked). I think I would be able to install Ubuntu then.

But I suddenly got a silly issue with the screen - I've probably held F11 somewhere and that turned the screen off, so I could not see neither BIOS nor Dell logo. So I put my laptop to the tech service and they've worked it out, but also reinstalled my Windows 10. This time that was MBR (legacy, non-UEFI).

And with the Windows MBR, Ubuntu installed like a charm.

Upon Ubuntu installation, I had the following setting in my BIOS:

  • Boot List Option: UEFI (I left it unchanged, not sure if this setting even took effect)
  • Secure Boot: disabled (I disabled it myself because many people reported issues on it)
  • Load Legacy Option Rom: disabled (left untouched)

Also, my BIOS was of the latest version (I followed dell.com website instructions to update BIOS).

After Ubuntu installation, the only issue I had is not being able to shut down properly. Resolved this by going to System Settings > Software & Updates > Additional Drivers and selecting this proprietary NVIDIA driver instead of an opensource one: "NVIDIA binary driver - version 361.42 from nvidia-361 (proprietary, tested)"

Now it works well. I am able to dual-boot Windows because I have it in MBR. I know this is probably not your case, but you may try acpi=off solution or migrating your Windows to MBR (if you know how to do it - 'cause I am not an expert there :).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.