4

I am having an issue with my sound which I am aware other user's have had before: Sound works perfectly on my Ubuntu install, except when I put my headphones in, the speakers are not disabled correctly.

The interesting thing is that, when inspecting the levels in alsamixer, a headphone connection is detected and the speaker channel is muted - however this has no effect It seems as though the headphone channel is played back through both the speakers and my headphones, as muting this channel mutes both physical devices. Also, when plugging in headphones, the Speakers are no longer visible in pavucontrol, or system sound settings.

I have tried various versions of options snd-hda-intel model=xxxx in /etc/modprobe.d/alsa-base.conf, including auto, generic,hp,laptop,hp-laptop, to no effect. Alsamixer also shows "Auto-Mute Mode" as enabled.

Laptop: HP Spectre x360, Ubuntu 14.04, PulseAudio 4.0.

Update: Upgraded to Willy Werewolf - the problem persists.

4

This turned out to be a problem with the pin mapping (a couple of speaker pins were set to use the headphones' output rather than the Speaker output).

I used ALSA's HDA-Analysier tool to debug this, and corrected the problem by changing the following pins:

0x17 to Audio Output 0x11
0x1d to Audio Output 0x11
0

I fixed this by running the command

alsamixer

and then pressing the right arrow key till I go to the Auto-Mute Mode (second from the farthest right). Press the down arrow to disable this service.

Also works on 16.04 Xenial.

http://ubuntuguide.net/fix-sound-still-coming-from-speakers-after-plug-in-headphones-on-ubuntu-10-04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.