1

Ubuntu 14.04. It detects wired connections but can't get an IP address. I've tried it with different wired networks and each time had the same problem, both with nm-applet and wicd. My other computer connects to my home network without a problem.

It's not blocked, soft or hard. I tried the suggestion here but it didn't change anything. One thing to note is that cable does not connect directly to the laptop but through a proprietary connector. Here is the output of ifconfig:

eth0      Link encap:Ethernet  HWaddr 24:f5:aa:c2:58:c7  
          inet6 addr: fe80::26f5:aaff:fec2:58c7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:378 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:8058 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8058 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2163118 (2.1 MB)  TX bytes:2163118 (2.1 MB)

wlan0     Link encap:Ethernet  HWaddr 6c:29:95:19:08:1b  
          inet addr:192.168.1.133  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6e29:95ff:fe19:81b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2280079 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1500378 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2912209727 (2.9 GB)  TX bytes:186227404 (186.2 MB)

Here is the contents of /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp

Here is the output of sudo lspci -vvnn | grep -iA 10 ethernet.

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
    Subsystem: Samsung Electronics Co Ltd Device [144d:c109]
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 61
    Region 0: I/O ports at e000 [size=256]
    Region 2: Memory at f7c00000 (64-bit, non-prefetchable) [size=4K]
    Region 4: Memory at f0000000 (64-bit, prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
        Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
8
  • have you already made a reset with your modem (cable-modem or w-lan modem?) - the modem has a reset-button and you could push this little button cautiously for 3 or 5 seconds. Mar 19, 2016 at 3:17
  • Could you show us what's in /etc/network/interfaces ?
    – 88weighed
    Mar 19, 2016 at 18:14
  • @dschinn1001 Yes, I have.
    – Reza
    Mar 20, 2016 at 13:41
  • @Reza is your Ethernet supposed to only be trying to get IPv6? Mar 21, 2016 at 0:44
  • I don't think so. As I said I've tried it with several different networks.
    – Reza
    Mar 21, 2016 at 0:50

2 Answers 2

1

set network configuration manually. for that, follow the below commands:

ifconfig eth0 192.168.31.3 netmask 255.255.255.0 up

(IP and NetMask is example)

sevice networking restart
3
  • Ah it seems to work! But why automatics configuration didn't wotk?
    – Reza
    Mar 22, 2016 at 1:12
  • It worked for the first time but not anymore.
    – Reza
    Mar 22, 2016 at 12:12
  • use dhcp by following command:dhclient -v and thenservice networking restart. if it doesn't work you must make a complete network troubeshoting
    – ansar313
    Mar 23, 2016 at 10:03
1

Add in /etc/network/interfaces

(this is example)

iface eth0 inet static
address 192.168.1.200
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1

Then

sudo /etc/init.d/networking restart

This way use static IP address.

3
  • I did so and applied the same settings in nm-connection-editor. It connects but I can't access the internet. Should I apply the same settings (for my laptop) in my router as well?
    – Reza
    Mar 23, 2016 at 10:03
  • Can you not resolve addresses, or you can't connect to any external IPs? For example, ping google.com doenst work, but ping 8.8.8.8 does? If so, add 'dns-nameservers 192.168.1.1' to the eth0 interface config. As you're just missing name resolution.
    – user508889
    Mar 24, 2016 at 14:37
  • Thanks for your input however if I only edit that file the nm-applet or wicd still can't get an IP address. I can edit the connection in the applet to have manual IP but then I don't think this will work for other wired network and my question was why Ubuntu can't get the IP address while the same computer with windows can.
    – Reza
    Mar 25, 2016 at 12:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .