I have an Ubuntu box which displays kodi fullscreen on my TV. It is started in /etc/rc.local via

/usr/bin/xinit /usr/bin/kodi

Today a toddler got hold of the keyboard for a split second and managed, though a keyboard combination, to switch the screen so that the kodi window now takes about 1/6th of the screen. It is in the upper-left corner, the rest of the screen is blank and when moving the mouse, the cursor changes from an arrow (while above the small screen) to a cross while outside.

It looks like the case where one starts xinit with just an xterm (which also takes that part of the screen).

(wild guesses follow) It may be that the keyboard combination instructed kodi to use a smaller resolution, or xinitto use a larger one (and thus pushing kodi into a smaller screen).

I rebooted the computer but it now boots into this configuration as well (so - wild guesses again - it may be that the keyboard combination switched a permanent parameter, but it was a split second so it could not have been much more than Ctrl-M-Shift-Left Arrow-P)

Since the conversational possibilities with the baby are tiny I would appreciate any pointer on where to look for a solution.

  • 1
    Could have been F11. Mar 13, 2016 at 16:46
  • To toggle between full screen and windowed mode press the backslash-key "\"
    – cmks
    Mar 13, 2016 at 20:15

2 Answers 2


In Kodi goto

System → Settings → System → Video output

Change the option "Display mode" from "Windowed" to "Full screen"

To toggle between "Windowed" and "Full screen" mode you also can use the keyboard shortcut \ (the backslash key). Look at Keyboard controls (Kodi wiki) for more Kodi keyboard shortcuts.


The key which toggled the modes was *.

I believe that it may be a shortcut for the other actions described in @cmks' answer (which did not work for me but may for others - fullscreen mode was already enabled)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .