I'm relatively new to Linux/Ubuntu (i.e. I mightn't understand overly detailed tech terms etc) and have come across the following problem:

I tried to install Ubuntu on a new (Jan 2016) MBP 11,5 with 16GB RAM in dual boot mode alongside OSX 10.11. I first installed rEFInd, which worked fine. Then I downloaded the Ubuntu 14.04.4 .iso and burned this to a USB stick. From this USB stick I can launch Ubuntu on the MBP without any problems, however, I cannot install Ubuntu due to the following errors:

When I tell the installer to update Ubuntu online during the install and download 3rd party apps, Ubuntu freezes during the Preparing to install... screen and never even lets me select a destination etc. If I don't select any update/download options, the installer starts running but never goes beyond the Configuring bcmwl-kernel-source (amd64) (I've waited for almost an hour now) though Ubuntu remains responsive at this point

The last entry in the install log is

Mar 13 09:23:17 ubuntu ubiquity: DKMS: install completed." and "Mar 13 10:17:01 ubuntu CRON[8738]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)

Three additional points to note:

  1. I tried installing Ubuntu both with System Integrity Protection enabled and disabled (as described on the rEFInd installation guide), this does not seem to have an effect on the Ubuntu install progress.
  2. The installer does not 'see' OSX, i.e. it does not provide me with the option of installing in Ubuntu alongside OSX; however, it does see the OSX partition. The installation attempts I mentioned above, all were done manually with a root partition (/) and a 16GB swap space partition
  3. I always launched the installer in Ubuntu (booted from the USB stick) and tried installing it with and without typing ubiquity -b in the terminal, neither worked.

Any help for a relative newbie would be hugely appreciated!

  • Update 1: I just wanted to let you know that installation worked in the end but only when installing directly from USB stick by not first booting into Ubuntu, otherwise I was not able to install Ubuntu. Now 14.04.4 is running on this 2016 Macbook pro 11,5; however, as described by others already, when shutting down or going to sleep Ubuntu freezes (does anyone know of a remedy for this, I could not find a solution anywhere)... – Michael Mar 13 '16 at 13:42
  • Please edit your question, when you want to add information. Especially file or program output listings (with the help of the {} button in the editor toolbar) are much more readable there and overall it's best to have everything relevant in one place. Also, comments may be deleted for various reasons. – David Foerster Mar 15 '16 at 9:36
  • I can't spot any issue with what you did so far. Which instructions did you follow during the installation? Maybe they're outdated or someone can tell you where you misinterpreted them. – David Foerster Mar 15 '16 at 9:39

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.