0

I have installed Ubuntu 14.04 and windows 8.1. I can boot both O.S using the BIOS boot options (manually). I want to select O.S from a grub screen when PC starts. So i tried to use a boot repair live CD to repair grub/boot. The problem is when I select "64-bit session" in the boot repair menu an error appears:

kernel panic at boot: not syncing. No init found

Pastebin: http://paste.ubuntu.com/15368305/

0

As per your boot-repair report(translated to English)

The boot files [ Linux ] are far from the beginning of the disc . Your BIOS could not detect them . You may want to retry after creating a partition / boot ( EXT4 , > 200MB , beginning of the disc ) . This can be done with tools like GParted . Then select this partition through the [ separate / boot partition ] of [Boot Repair ] . ( Https://help.ubuntu.com/community/BootPartition )

If your computer boots directly into Windows , try changing the boot order in the BIOS.
If your BIOS does not support changing the boot order , change the default entry in the Windows boot loader .
For example you can start Windows , then type the following command in a cmd window with administrator privileges :
bcdedit / set { bootmgr } path \ EFI \ ... \ grub * .EFI

I won't take the first point very seriously...but the second one is worth trying

For example you can start Windows , then type the following command in a cmd window with administrator privileges :

bcdedit / set { bootmgr } path \ EFI \ ... \ grub * .EFI

Give this a try.

0

Perhaps you could give it a try with Super GRUB 2 disk.

You can download it from here.

Then install it in a usb using Unetbootin Now you could restart your system and make sure it is set in the boot option menu.

  • I tried with Super grub2. When I select "Detect any OS" it shows me only Linux options – Adrián E. Mar 13 '16 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.