I'm trying to install the package LaTeXila, and the output looks like this:

$ sudo apt-get install latexila --no-install-recommends
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  latexila-data latexmk luatex tex-common texlive-base texlive-binaries
  texlive-common texlive-doc-base texlive-latex-base
Suggested packages:
  rubber texlive-latex-extra debhelper
Recommended packages:
  texlive texlive-latex-recommended texlive-luatex lmodern
The following NEW packages will be installed:
  latexila latexila-data latexmk luatex tex-common texlive-base
  texlive-binaries texlive-common texlive-doc-base texlive-latex-base
0 upgraded, 10 newly installed, 0 to remove and 0 not upgraded.
Need to get 29.3 MB of archives.
After this operation, 74.5 MB of additional disk space will be used.
Do you want to continue [Y/n]?

I don't want to install the texlive packages. I've installed texlive manually from http://www.tug.org/texlive/. Any suggestions?

  • add the program and then remove the packages you don't want. When you install a program like that you just download/install a set of packages. You need to change what is included in the package and you can't do that as a user.
    – Alvar
    Commented Nov 1, 2011 at 20:22
  • 16
    There really should be some power-user capability here. It should either let me install things without specific dependencies, or let me claim that something is installed even if it isn't actually installed. If I wanted to be treated like I don't know what I'm doing, I'd stick to using Windows.
    – Alex
    Commented Nov 15, 2011 at 8:38
  • well if you really don't want the whole package, then just install the specific files and hope it works.
    – Alvar
    Commented Nov 15, 2011 at 14:56
  • 2
    alex - I think I may have inadvertently cast the downvote. I have a longtime habit of scrolling web pages down the left side on a touchpad. On this site I've had this happen a few times, possibly I didn't notice happening on yours. (wish voting had a confirmation) . Another solution to your issue is to create an equivs package. Not the simplest for something like texlive though doable. Some info here and a linked example - tug.org/texlive/debian.html
    – doug
    Commented Nov 19, 2011 at 18:35

4 Answers 4


apt-get won't do this, but dpkg will.

apt-get download latexila latexila-data

That will download the binary .deb files but will not attempt to install them.

Now you can use dpkg to force install them.

dpkg --force-all -i <name of the .deb files you downloaded>

I will echo the warning in the dpkg man page here:

Warning: These options are mostly intended to be used by experts only. Using them without fully understanding their effects may break your whole system.

If your system is broken after attempting this, you can just try to remove latexila and latexila-data. Good luck.

  • This should be marked as the answer, very simple and straight to the point method.
    – Severo Raz
    Commented Dec 17, 2012 at 19:49
  • Great answer. I wanted to install asciidoc just to write documentation in the form of a manpage and HTML. 382 megabytes of latex garbage! Now I have just the asciidoc, thanks.
    – Kaz
    Commented Feb 28, 2014 at 4:22
  • 5
    @WolterHellmund This should absolutely not be the accepted answer, because ignoring dependencies results in an inconsistent database that will cause trouble when you upgrade packages or install related packages. The right solution is equivs, as recommended by henrique. Commented May 12, 2014 at 21:09

Here are the instructions following the TUG page on TeX Live and Debian/Ubuntu:

  1. Install vanilla TeX Live as root, system-wide.
  2. Ensure that the only Debian TeX Live packages installed are tex-common, texinfo, and perhaps lmodern.
  3. Add TeX Live's bin directory to ENV_PATH in /etc/login.defs.
  4. Tell APT about your TeX Live installation by building a dummy package using equivs:

    $ aptitude install equivs # as root
    mkdir /tmp/tl-equivs && cd /tmp/tl-equivs
    equivs-control texlive-local
    # edit texlive-local (see below)
    $ equivs-build texlive-local
    $ sudo dpkg -i texlive-local_2011-1_all.deb

At the step "edit texlive-local", edit the Maintainer field and the list of the packages provided by your local TeX Live installation as appropriate. If you installed scheme-full except collection-texinfo as recommended, the file should look like this example

(Basically, one has to create a dummy package to fool apt-get)

For other ways, see also How to install “vanilla” TeXLive on Debian or Ubuntu? on TeX.SX.

  • 2
    I think this is the correct answer. Commented Mar 24, 2014 at 5:51

Find the list of packages that are not meeting dependency.

Download the .deb file with apt-get download. Then use

sudo dpkg -i --ignore-depends=<package(s) to ignore> package.deb


after doing

aptitude install [packagename]

You have the question if you want to install all packages that are mentioned.. if there is a package you do not want to have installed like mysql-server because it is offloaded to another server insted of answering y/n answer with


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .