3

I'm trying to disable a service:

$ sudo update-rc.d mysql disable
update-rc.d: warning:  start runlevel arguments (none) do not match mysql Default-Start values (2 3 4 5)
update-rc.d: warning:  stop runlevel arguments (none) do not match mysql Default-Stop values (0 1 6)
 System start/stop links for /etc/init.d/mysql do not exist.

What does that mean? How can I disable it then?

7

It means that the service in the SysVInit system is not enabled. The mysql is rather started through upstart in /etc/init.

To disable auto start of mysql.

echo "manual" > /etc/init/mysql.override 
| improve this answer | |
  • that file doesn't exist. – Alan Coromano Mar 12 '16 at 17:03
  • 3
    Yes, correct. You have to create it. – Thomas Mar 12 '16 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.