I'm trying to install OPENBLAS from git. I've cloned the directory and when I run make NO_AFFINITY=1 USE_OPENMP=1 I get this error

make[1]: Entering directory `/home/sandesh/OpenBLAS/test'
gfortran -Wall -m64   -o sblat1 sblat1.o ../libopenblas_haswellp-r0.2.16.dev.a -lm -lpthread -lgfortran -lm -lpthread -lgfortran 
gfortran -Wall -m64   -o dblat1 dblat1.o ../libopenblas_haswellp-r0.2.16.dev.a -lm -lpthread -lgfortran -lm -lpthread -lgfortran 
gfortran -Wall -m64   -o cblat1 cblat1.o ../libopenblas_haswellp-r0.2.16.dev.a -lm -lpthread -lgfortran -lm -lpthread -lgfortran 
gfortran -Wall -m64   -o zblat1 zblat1.o ../libopenblas_haswellp-r0.2.16.dev.a -lm -lpthread -lgfortran -lm -lpthread -lgfortran 
gfortran -Wall -m64   -o sblat2 sblat2.o ../libopenblas_haswellp-r0.2.16.dev.a -lm -lpthread -lgfortran -lm -lpthread -lgfortran 
gfortran -Wall -m64   -o dblat2 dblat2.o ../libopenblas_haswellp-r0.2.16.dev.a -lm -lpthread -lgfortran -lm -lpthread -lgfortran 
gfortran -Wall -m64   -o cblat2 cblat2.o ../libopenblas_haswellp-r0.2.16.dev.a -lm -lpthread -lgfortran -lm -lpthread -lgfortran 
gfortran -Wall -m64   -o zblat2 zblat2.o ../libopenblas_haswellp-r0.2.16.dev.a -lm -lpthread -lgfortran -lm -lpthread -lgfortran 
gfortran -Wall -m64   -o sblat3 sblat3.o ../libopenblas_haswellp-r0.2.16.dev.a -lm -lpthread -lgfortran -lm -lpthread -lgfortran 
gfortran -Wall -m64   -o dblat3 dblat3.o ../libopenblas_haswellp-r0.2.16.dev.a -lm -lpthread -lgfortran -lm -lpthread -lgfortran 
gfortran -Wall -m64   -o cblat3 cblat3.o ../libopenblas_haswellp-r0.2.16.dev.a -lm -lpthread -lgfortran -lm -lpthread -lgfortran 
gfortran -Wall -m64   -o zblat3 zblat3.o ../libopenblas_haswellp-r0.2.16.dev.a -lm -lpthread -lgfortran -lm -lpthread -lgfortran 
./sblat1: /home/sandesh/anaconda/lib/libgfortran.so.3: version `GFORTRAN_1.4' not found (required by ./sblat1)
make[1]: *** [level1] Error 1
make[1]: *** Waiting for unfinished jobs....

My gcc compiler is gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu9) and I believe fortran is already 1.4 in gcc 4.8.1

I feel the problem is that the compiler is using the gcc from the folder anaconda which I had installed last week. How should I point the make command to use my default gcc compiler ?


Guys I found a work around here by using this command ....
Seems like the libfortran from the anaconda folder was causing issue so I tried to use my default libfortran which happened to be of correct version ...
LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libgfortran.so.3.0.0:/usr/lib/x86_64-linux-gnu/libgfortran.so.3 make NO_AFFINITY=1 USE_OPENMP=1
Reference: answer by flying sheep

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.