0

I have recently returned to Linux and am attempting to setup my new PC rig. I've run into issues with the way my monitors are setup. I have done a fresh install of Lubuntu (You can view the version here).I have connected two identical BenQ monitors to my GTX 980 both running DVI-DVI interfaces. Because they are both using DVI when I run zrandr the only interface I am able to see if DVI-O (See the output here and correct me if I am wrong).

Using the GUI Monitor tool I am experiencing the same fault where it only detects one monitor as the output. I doubt this was a driver fault but I have tested Using X.Org Z Server - Nouveau display driver and Nvidia Binary Driver version 352.63 and neither have allowed me to expand the screen (not that I expected it to). Just to confirm, the following may be of help: LSMOD command.

Now I have attempted to run the ARandR tool to see if it is able to distinguish the difference, but AFAIK it's just a front end for running a script to amend the display settings, similar to the default tool.

Is there any method I can use to have both screens run using DVI interfaces and have them extend and not duplicate?

Update 1

Using my GTX 980, I run the top screen off HDMI to DVI and the second screen natively DVI to DVI, I receive the same fault as above.

Update 2

I am running one BenQ from HDMI to HDMI as the main display and the other display as DVI to DVI. Randr and the default application now notice it as a display yet the monitor itself indicates it has no video input - the HDMI cable cannot be faulty on this, as I nicked it from my other PC rig just now to test.

Update 3

I have been looking around in the community and have found the following:

Second Monitor not powering on yet detected

Second Monitor blacks out

0

Check the BIOS settings and make sure any other graphics is turned off except for the 980. Also make sure you are using the Nvidia driver. I am using two monitors on Ubuntu 14.04. There is a display setting that shows the monitor positions and if it shows the extended display you should be seeing that on your screens. I turned off the sticky edges and turned off the Mirror displays in the screen display settings. Also set the launcher in the left display.

0

There was no real solution to this issue, I was required to use a DVI and Display Port adapter on the same graphic card to extend the two monitors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.