0

I have just recovered my Laptop from a GRUB issue now when I want to login, the screen splashes and go back to login screen, I can login fine using terminal, Some people say you need to reset unity but the problem is my WiFi don't work idk the reason. I tried to reset unity via Dconf reset -f /org/compiz command but it says: cannot autolunch d-bus without x11 $display

0

have you tried restart the lightdm service.
or u can do : apt-get install --reinstall ubuntu-session
as per this url:
http://sourcedigit.com/16407-how-to-fix-failed-to-start-session-at-ubuntu-login/

and if problem still exists than try to login as a guest account, if succeeded than go back to ctrl+alt+f1 check the permission & ownership of your user:
ls -la /home/user
check optput of these files:
drwx------ 3 user user 4096 Aug 6 2015 .gnome
-rw------- 1 user user 49 Jan 1 2010 .Xauthority
if permission are not like this than set the permission and also do chown to user for all files in the user & reboot system, hope this will solve your problem.

  • the apt-get command requires network connectivity? guest session don't work as well – moein rahimi Mar 12 '16 at 8:30
  • so now go with second solution which i have mentioned, problem can caused because of permissions also, rm the existing .Xauthority file and give the full permission chmod -R 777 /home/user and make user the owner of all files with chown -R user:user /home/user and reboot. (reboot will create again new .Xauthority file) – anand Mar 12 '16 at 8:57
  • still the same, nothing changed – moein rahimi Mar 12 '16 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.