0

I'm using Ubuntu desktop but it's primarily used as a server. I have data being stored on external drives that the server needs to access, but after rebooting, the drive doesn't appear through terminal commands. For example, if I reboot I get this when looking for the drive:

$ cd /media/user && ls
$

Nothing gets returned when looking for where the drive should be. However, if I open up the GUI file explorer and go to the drive, it's there, and after opening up the drive's folder, I can run the same command again:

$ cd /media/user && ls
data1
$

And it's there and everything works fine after that. How can I have it automatically show up there on startup without having to use the GUI?

0

You can see if it is mounted (and with which options) with mount (when the disk IS mounted) see man mount), find its UUID with sudo blkid -o export (will show all devices) (see man blkid), and arrange for it to be mounted by editing /etc/fstab (see man fstab). You should look at the auto parameter.

  • Thanks! I also found gnome-disks has an easy GUI method for this but I used your method and worked fine. – George Barnick Mar 12 '16 at 7:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.