1

I am trying to copy files from an external hard drive (NTFS) onto an internal drive (ext4). Almost all of the files were successfully copied, but some were not.

If I navigate into the directory with one of the problematic files and type ls -l, I am listed as the user/group for that file and have rw permissions.

I tried copying using sudo and by elevating to root, with still no luck.

These files were originally put on the drive by a Windows 7 machine and all have the extension .R

EDIT: This is the exact output I get:

cp coldiss.R ~/Desktop/coldiss.R
cp: reading `coldiss.R': Permission denied
cp: failed to extend `/home/bwroga/Desktop/coldiss.R': Permission denied

sudo cp coldiss.R ~/Desktop/coldiss.R
(password prompt omitted)
cp: reading `coldiss.R': Permission denied
cp: failed to extend `/home/bwroga/Desktop/coldiss.R': Permission denied
  • Can 1 of those problem files be copied to another system? Make sure you proof it is the destination is the problem otherwise this is a windows problem and probably some sort of lock is in place if that is possible. Otherwise you only need to check the ext4. – Rinzwind Mar 11 '16 at 18:34
  • Does NTFS support such stuff as hard links or any other kind of file descriptors that is incompatible with ext4 or are not transferable to other devices generally? Also, what is the exact error message you get when trying to copy the files? – Byte Commander Mar 11 '16 at 19:16
  • @Rinzwind That was a good suggestion. I was unable to copy the files onto a Windows machine. These files were unintentionally encrypted by a different Windows machine. – bwroga Mar 13 '16 at 4:00
  • @ByteCommander I don't know the answers to your questions, but added the error messages to my post. – bwroga Mar 13 '16 at 4:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.