2

I have an ASUS K501LX, that has a Wireless-ac 7265. I've just installed Ubuntu 15.10, but I can't enable WiFi. I guess it's because of drivers. I have read many posts and articles about people having the same problems on Ubuntu, but I still can't get it working. I have some drivers on Intel's website but I'm not able to install it. How should I proceed in attempting to install drivers for my wireless card?

Result of rfkill list all

1: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: asus-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

Result of dmesg | grep iwl

[    2.170941] iwlwifi 0000:03:00.0: Unsupported splx structure
[    2.197025] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-7265D-19.ucode failed with error -2
[    2.217697] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-7265D-18.ucode failed with error -2
[    2.226666] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-7265D-17.ucode failed with error -2
[    2.231556] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-7265D-16.ucode failed with error -2
[    2.231587] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-7265D-15.ucode failed with error -2
[    2.380682] iwlwifi 0000:03:00.0: loaded firmware version 25.30.14.0 op_mode iwlmvm
[    2.575281] iwlwifi 0000:03:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[    2.575437] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[    2.575666] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[    2.598957] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    2.601838] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
  • Please edit your question to add the result of these terminal commands: rfkill list all and also: dmesg | grep iwl Welcome to askubuntu. – chili555 Mar 11 '16 at 18:00
  • @chili555 i have edited, please take a look – Giorgi Khmaladze Mar 11 '16 at 19:13
4

Your wireless is hard blocked:yes which means that the wireless switch or key combination is set to turn the wireless radio off. In the case of a number of Asus laptops, the kernel doesn't correctly recognize key presses, perhaps Fn+F2. Let's try to get the key presses working as expected. Please open a terminal and do:

sudo -i
echo "options asus_nb_wmi wapf=1" > /etc/modprobe.d/asus.conf
exit

Reboot and see if your wireless is working after you manipulate the wireless key combination.

If the above does not work, redo it again but replace asus_nb_wmi wapf=1 with asus_nb_wmi wapf=4, reboot and check again.

Also, you can get later firmware to possibly improve wireless performance. With a working internet connection, please do:

sudo apt-get update
sudo apt-get install git
git clone https://github.com/OpenELEC/iwlwifi-firmware.git
cd iwlwifi-firmware/firmware
sudo cp iwlwifi-7265*  /lib/firmware

Reboot.

  • 1
    Just for the benefit of the searchers, was it wapf=1 or was it wapf=4 that worked for your Asus K501LX? – chili555 Mar 12 '16 at 14:20
  • it was wapf=1 that helped me :) – Giorgi Khmaladze Mar 14 '16 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.