0

I ran apt-get upgrade on Ubuntu 12.04 LTS and it did not finish due to an error (run out of free inodes). After reboot the GRUB menu appeared and when tried to boot my OS it displayed:

/dev/disk/by-uuid/xxxxxxxxx does not exist. Dropping to a shell

initramfs:_

What is a solution to this?

1

I'm posting this as a reference for myself. Yes, there are other answers to this problem but this is a bit different.

Instead of booting from liveDVD as other answers suggest, you may display GRUB menu at boot (e.g. by pressing and holding the Shift key) and then choose 'Advanced options for Ubuntu' in Ubuntu 14 LTS (in Ubuntu 12 LTS it is 'Previous linux versions'). Confirm the uppermost/latest version to boot. When OS is up and running, you may perform the following procedure.

sudo mount /dev/sda1 /mnt 
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt
update-initramfs -u
update-grub
reboot

Note that you should verify that /dev/sda1 is really your boot disk.

Procedure was suggested here.

Update:

Is anybody aware of potential problems due to the fact that my solution uses the older version of the OS? By now, system where this was applied, works fine.

0

You need to repair your boot partition. Use a bootable USB and run this command for your boot partition (which I assume it is /dev/sda1):

sudo fsck -a /dev/sda1
1
  • 1
    Thank you. Found a quick alternative to do the same: sudo touch /forcefsck as suggested in this post. – Franc Drobnič Mar 11 '16 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.