0

Problem: The other day, I logged in to my work laptop to find the default fonts had gotten larger, meaning names of apps on the Whisker menu didn't fit, desktop icon names were truncated, the system bar was cramped and the entire UI was cramped. (aside: I reduced the font sizes initially and / or dpi , because the laptop display resolution 1360 x 768 doesn't leave much room for desktop operations; so reverting to the original setting is a distinct possibility) I logged off and on again without success, then rebooted and logged in again to find my DE returned to my preferred settings and thought nothing of it. Logging on today I see the same, and no amount of resetting or rebooting is curing the issue.

Analysis: I have discovered that no changes made to the Xfce interface via System->Appearance->Fonts make any difference to the rendering of my DE. Neither font face, style, size, anti-aliasing or DPI. In fact, none of the settings in the Appearance applet seem to have any effect on the desktop, from icons to widget themes, even after a reboot and I recall them responding pretty instantly in the past.

Supposition: Has this applet lost the right to alter these configurations at a lower level? I don't even know how to test that theory, or where these settings are stored.

Info: The installed system is 14.04, and updates come through sporadically in work. (better if I take the laptop home and let it update on my home network) Xfce About dialogue reports 4.10. Any other details or reports, just let me know what you want me to run.

I hope someone can help me resolve this, as it's quite difficult to fit everything on screen this big.

0

Can you change settings via the Settings Editor? Font and DPI settings are located under "xsettings." You could also try changing settings by xfconf-query with a command like the following and also see if it shows any kind of error:

xfconf-query -c xsettings -p /Gtk/FontName -s "DejaVu Sans 10"

You could see if this works to change the DPI:

xfconf-query -c xsettings -p /Xft/DPI -s "96"

You may also want to make sure you are the owner of these files by running the following. You should be owner, but perhaps something strange happened.

ls -l ~/.config/xfce4/xfconf/xfce-perchannel-xml

You could always try upgrading from Xfce 4.10 to 4.12. I have used 4.12 for a while now on Xubuntu 14.04 on two different computers and it works great. There is documentation online for this such as this article.

I hope this answer can be of benefit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.