I recently created a partition on my Macbook Pro (late 2013 release) to run Ubuntu, following this tutorial.

I managed to have it running smoothly, but I need to update the Kernel to 4.4. I've been following this website's instructions but once I reboot my computer and log back in and run uname -r, the Kernel is still 4.2.0-30-generic. I've also tried pressing Esc to see GRUB, but the apparently installed Kernel 4.4 doesn't appear on the list.

Any ideas?


After Hyltixa helped me, it seems that GRUB is the problem here. After running sudo update-grub this shows up:

Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-4.4.0-040400-generic
Found initrd image: /boot/initrd.img-4.4.0-040400-generic
Found linux image: /boot/vmlinuz-4.2.0-30-generic
Found initrd image: /boot/initrd.img-4.2.0-30-generic
Found linux image: /boot/vmlinuz-4.2.0-27-generic
Found initrd image: /boot/initrd.img-4.2.0-27-generic
Found Mac OS X on /dev/sda5

which shows that the files did in fact get installed. But GRUB is not showing them as options when booting


Here's a snapshot of the grub-customizer tool:

enter image description here

3 Answers 3


Dunno if it should work any different for Ubuntu users than Elementary OS, but to upgrade from 4.2 (or whatever kernel) to the released "LTS" version of 4.4, you can use:

sudo apt-get install linux-generic-lts-xenial

Use : apt-cache search linux|grep xenial to check what is available. If nothing is found, you have to select the correct sources for your distro :)


I noticed that /boot/grub/grub.cfg did not have the proper kernel list in it... after some more searching, the second answer here worked for me:

sudo exec grub-mkconfig -o /boot/grub/grub.cfg


I did that on my elementaryOS and it worked fine! Just make sure you get the right files when you download them, AND you install them in this order.

linux-headers-4.4.0-xxx_all.deb linux-headers-4.4.0-xxx-generic_xxx_i386/amd64.deb linux-image-4.4.0-xxx-generic_xxx_i386/amd64.deb

  • Thanks Hyltixa, I did it exactly as in the website for the 64-bit, line by line, but the kernel just won't update :'(
    – MrRed
    Mar 10, 2016 at 23:26
  • Do you use the software app to start the 3 debfiles or terminal ?
    – Hyltixa
    Mar 10, 2016 at 23:27
  • I used the terminal. Give me a minute, I will send you my ID in a sec
    – MrRed
    Mar 10, 2016 at 23:32
  • Great, trying to fix my teamviewer to! :)
    – Hyltixa
    Mar 10, 2016 at 23:33
  • Hi again! Try using the grub-customizer according to the answer to this question you find here, there you can easy modife grub and the order in grub, try to see with this app if you can make any changes to the grub to make the 4,4 kernel to show up as boot alternativ ! askubuntu.com/questions/100232/…
    – Hyltixa
    Mar 11, 2016 at 1:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .