Thanks for taking the time.

I have a problem I've never had after an upgrade. One of my hard drive, a 1TB NTFS drive connected with the marvell SATA connector (88sx or smth like that ) to my Asus P5Q-E motherboard is not seen, and therefore unmountable in Ubuntu.

The problem isn't with the drive or other hardware, because windows 7 sees it fine (in dual boot). Plus it worked just fine before I upgraded. And so for nearly a year.

The problem isn't with NTFS libs, because Ubuntu sees the win7 NTFS partition just fine.

So I can only guess that the problem is with ubuntu. Because the 10.10 live CD doesn't see it iether. The 10.04 LiveCD ,however, does see it and mounts the drive, which means it really is 10.10's problem. What should I do?.... Downgrading excluded :-) ! See images for proof.



I've tried updating grub (someone suggested it might work...), installing all the ntfs libs, adding it to fstab (as it was before, in 10.04),...but all that failed. Grub update did Nothing, niether did the ntfs libraries. The fstab edit just caused the boot time to take hours, and come back with errors saying it couldn't mount the drive, but not really saying why.

Any idea for resolving my bug? Thanks.

  • I assume that when you look under /dev/ there is no /dev/sdc either (GParted hides some devices if it thinks it can't support them properly)? You might also want to check dmesg (kernel log messages) if there is anything about that controller/drive in there.
    – JanC
    Oct 15, 2010 at 10:46
  • Test with sudo fdisk -l to see if it is listed
    – emf
    Oct 15, 2010 at 17:36

3 Answers 3


Think it is Linux kernel problem.

Have a Asus P5Q Premium with SIL5723 and I guess Marvell drivers (61xx / 88se6121). Everything was working nice when running 10.04. After installing 10.10 Ubuntu would not recognise disks on the SIL5723. I have part of a Raid 6 on these connectors. ICH10 disks no problems.

Running old rescueCD showed Raid was ok. Also recognised by BIOS and see disks when starting the PC. With Ubuntu Live CD 10.10 same problem. Raid however not destroyed as Raid not mounted.

Started 10.10 today with kernel 2.6.32 and raid mounted and working perfect. Guess 2.6.32 is long term stable release. However with this kernel I'm not able to run Gparted and there might be other problems as well. Guess 2.6.32 was available as upgraded and did not do a fresh install.

Looks this is a Linux kernel (2.6.35) problem. I'm not able to find Marvell drivers to install. Not keen on going back to 10.04 either.

Per Arne


see above comment re. testing with sudo fdisk -l.

Also, I'm no expert here, but I know that each system device has some sort of system bus parent device that should be recognized by your motherboard. With PCI devices, if you type lspci -v -t it will give you a "tree view" format output of all pci devices, with parents. For example, my ethernet card and wireless card are listed under parent of the motherboard Ethernet controller. I do not know if SATA devices fall under this category, but I think a sudo lshw should cover hard drives and SATA devices. Do so and see if your device is listed.

This is not an answer but hopefully may help lead you to one.


Hey. I'm answering my own question, but that might help some people. Yesterday, I did a nice and big Kernel upgrade and it fixed my problem. The new kernel is 2.6.35-23-generic To upgrade the Kernel, come here After that, I suggest you run

sudo apt-get update && sudo apt-get dist-upgrade

Worked for me. Don't really know what had to be fixed in the kernel, or why it'd disappeared, but that fixed it!

Thanks for your help and input.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .